Автор Тема: Веб-камера в ноутбуке toshiba satelite c850-blk [решено]  (Прочитано 1505 раз)

Оффлайн stanukih

  • Давно тут
  • **
  • Сообщений: 556
Здравствуйте. Решил попробовать установить скайп на alt linux kdesktop 7.0. Установка прошла нормально, но отказалась заводиться веб-камера. Прочитал кучу инструкций с выполнением тамашних советов. Обновил систему и ядро. Ноль эмоций. Программа kamoso так же не видит её (даже под root). Хотел спросить что можно сделать чтоб она заработала.
решено
« Последнее редактирование: 19.03.2014 21:20:08 от sb »

Оффлайн stanukih

  • Давно тут
  • **
  • Сообщений: 556
Если пригодиться то вот:
[root@comp-pentium-cpu-af82bc ~]# lsusb
Bus 001 Device 002: ID 0930:021d Toshiba Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 004: ID 04ca:7008 Lite-On Technology Corp.
Bus 004 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 
« Последнее редактирование: 13.07.2014 18:36:00 от МИНЗДРАВ »

Оффлайн stanukih

  • Давно тут
  • **
  • Сообщений: 556
Да и файла /dev/video0  нет.

вот еще что получил:
[stas@comp-pentium-cpu-af82bc ~]$ dmesg
...........................................................................
[   14.140357] usb 3-1.1: New USB device found, idVendor=0bda, idProduct=0138
[   14.140369] usb 3-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   14.140376] usb 3-1.1: Product: USB2.0-CRW
[   14.140381] usb 3-1.1: Manufacturer: Generic
[   14.140386] usb 3-1.1: SerialNumber: 20090516388200000
[   14.217490] usb 3-1.3: new high-speed USB device number 4 using ehci-pci
[   14.437594] usb 3-1.3: New USB device found, idVendor=04ca, idProduct=7008
[   14.437606] usb 3-1.3: New USB device strings: Mfr=3, Product=1, SerialNumber=0
[   14.437613] usb 3-1.3: Product: TOSHIBA Web Camera
[   14.437618] usb 3-1.3: Manufacturer: 0420-00C40TBC3E3KL
.............................................................................



[stas@comp-pentium-cpu-af82bc ~]$ /usr/sbin/lsusb
Bus 001 Device 002: ID 0930:021d Toshiba Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 004: ID 04ca:7008 Lite-On Technology Corp.
Bus 004 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
« Последнее редактирование: 13.07.2014 18:36:24 от МИНЗДРАВ »

Оффлайн stanukih

  • Давно тут
  • **
  • Сообщений: 556
Проблема решилась очень просто, а именно установил в synaptic kernel-modules-v4l-un-def#1:3.13.6-alt1,    libev4,   v4l2ucp,   v4l-utils.
Далее по этой инструкции http://www.altlinux.org/%D0%92%D0%B5%D0%B1%D0%BA%D0%B0%D0%BC%D0%B5%D1%80%D0%B0_%D0%B2_Skype   Ввел вот эту команду:   # echo "export LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so">>/etc/bashrc
Она прекрасно запустилась. Возможно еще какойто модуль или пакет пропустил при написании этого. Искал пакеты поиском в synaptic по v4l.