Автор Тема: k3b  (Прочитано 473 раз)

Оффлайн Koi

  • Мастер
  • ***
  • Сообщений: 1 381
  • валар дохаэрис
    • Канал на youtube
k3b
« : 29.10.2015 17:17:07 »
K3b - это приложение для записи и считывания CD/DVD/Blu-Ray.
Официально K3b не входит ни в один из компонентов KDE и выпускается независимо от него, однако для своей работы использует kdelibs.
Программа имеет графический интерфейс реализованный на QT.
Удобный интерфейс нацелен на любую аудиторию, пытаясь быть простым настолько, насколько это возможно, а также предоставлять все возможности, которые могут понадобиться продвинутым пользователям.
K3b оптимизирован для работы в среде KDE, имеет тесную интеграцию с аудиоплеером Amarok и позволяет записывать CD используя базу его тегов.
K3b автоматически выбирает наиболее подходящие настройки записи. Есть возможность создавать шаблоны настроек для разных категорий записей.
Для среды TDE есть отдельный пакет k3b.

Особенности:
Режим многосессионности.
Поддержка формата Rockridge.
Копирование CD, AudioCD, DVD-/+R(W).
Автоподготовка к записи CD-RW, DVD-/+RW.
Работа с образами ISO, CUE, BIN.
Перекодирование WAV в MP3, FLAC, Ogg Vorbis.

Руководство пользователя по K3b
Сайт программы: http://k3b.org/
« Последнее редактирование: 30.10.2015 17:08:20 от Koi »

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 576
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: k3b
« Ответ #1 : 30.10.2015 09:59:14 »
Есть версия для TDE и KDE4

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 576
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: k3b
« Ответ #2 : 30.10.2015 10:00:15 »
Описана версия для KDE4

Оффлайн Koi

  • Мастер
  • ***
  • Сообщений: 1 381
  • валар дохаэрис
    • Канал на youtube
Re: k3b
« Ответ #3 : 30.10.2015 12:04:00 »
А TDE разве не kdelibs использует? Это вроде 3 kde ?
На сайте у них не вижу сборку именно для TDE.
http://k3b.org/download
И в репах у нас таких вроде нет, или я опять что-то пропустил из-за невнимательности.

Кстати скачал сборку альта от Drool с TDE на р6, очень понравилась, легенькая быстрая, прямо мечта.
Может в далеком будущем тоже попробую что-то собрать, уж больно подмывает.
« Последнее редактирование: 30.10.2015 12:12:54 от Koi »

Инфлэйм

  • Гость
Re: k3b
« Ответ #4 : 30.10.2015 12:47:27 »
А TDE разве не kdelibs использует? Это вроде 3 kde ?
На сайте у них не вижу сборку именно для TDE.
http://k3b.org/download
И в репах у нас таких вроде нет, или я опять что-то пропустил из-за невнимательности.
$ apt-cache search k3b
k3b - Программа записи CD (Полный набор)
k3b-devel - Программа записи CD (Пакет разработчика.)
k3b-mini - Программа записи CD
kde4-k3b - Программа записи CD (Полный набор)
kde4-k3b-devel - Программа записи CD (Пакет разработчика.)
libk3bdevice6 - KDE 4 library
libk3blib6 - KDE 4 library
i586-k3b - The CD Kreator (Complete set)
i586-k3b-mini - The CD Creator
i586-kde4-k3b - The CD Kreator (Complete set)
i586-kde4-k3b-devel - The CD Kreator (Development package.)
i586-libk3bdevice6 - KDE 4 library
i586-libk3blib6 - KDE 4 library
k3b-i18n - Многоязыковая поддержка для утилиты записи CD k3b.
kino-dvdauthor - K3B/dvdauthor integration
Все что не kde4 уезжает в TDE

Для примера, список зависимостей программы, обратите внимание на первое
$ apt-cache depends k3b
k3b-1.0.5-alt13
  Требует: kdelibs >= 3.2
  Требует: wodim
  Требует: cdrkit
  Требует: cdrdao
  Требует: <mkisofs>
    genisoimage-1:1.1.11-alt1.qa1
  Требует: dvd+rw-tools
  Требует: libdvdcss
  Требует: libdvdread
  Требует: dbus
  Требует: libacl
  Требует: libattr
  Требует: iceauth
  Требует: libcdparanoia
  Требует: lame
  Требует: libmad
  Требует: libvorbis
  Требует: libmpcdec
    libmpcdec5-1.2.6-alt4
  Требует: libsndfile
  Требует: libmusicbrainz
  Требует: sox
  Требует: transcode
  Требует: <libflac++>
    libflac++6-1.2.1-alt11
  Требует: vcdimager >= 0.7
  Требует: normalize
  Требует: libtag
  Требует: k3b-mini = 1.0.5
  Требует: <libFLAC++.so.6()(64bit)>
    libflac++6-1.2.1-alt11
  Требует: <libc.so.6(GLIBC_2.14)(64bit)>
    glibc-core-6:2.17-alt8
  Требует: <libc.so.6(GLIBC_2.2.5)(64bit)>
    glibc-core-6:2.17-alt8
  Требует: <libc.so.6(GLIBC_2.4)(64bit)>
    glibc-core-6:2.17-alt8
  Требует: <libk3b.so.3()(64bit)>
    k3b-mini-1.0.5-alt13
  Требует: <libk3bdevice.so.5()(64bit)>
    k3b-mini-1.0.5-alt13
  Требует: <libkdecore.so.4()(64bit)>
    kdelibs-3.5.13.2-alt2
  Требует: <libkdecore.so.4(CXX3)(64bit)>
    kdelibs-3.5.13.2-alt2
  Требует: <libkdeui.so.4()(64bit)>
    kdelibs-3.5.13.2-alt2
  Требует: <libkio.so.4()(64bit)>
    kdelibs-3.5.13.2-alt2
  Требует: <libm.so.6(GLIBC_2.2.5)(64bit)>
    glibc-core-6:2.17-alt8
  Требует: <libmad.so.0()(64bit)>
    libmad-0.15.1b-alt7
  Требует: <libmp3lame.so.0()(64bit)>
    liblame-3.99.5-alt1
  Требует: <libmpcdec.so.5()(64bit)>
    libmpcdec5-1.2.6-alt4
  Требует: <libogg.so.0()(64bit)>
    libogg-1.3.0-alt1
  Требует: <libpthread.so.0(GLIBC_2.2.5)(64bit)>
    glibc-pthread-6:2.17-alt8
  Требует: <libqt-mt.so.3()(64bit)>
    libqt3-3.3.8d-alt4.M70P.1
  Требует: <libqt-mt.so.3(CXX3)(64bit)>
    libqt3-3.3.8d-alt4.M70P.1
  Требует: <libsamplerate.so.0()(64bit)>
    libsamplerate-0.1.8-alt1
  Требует: <libsamplerate.so.0(libsamplerate.so.0.0)(64bit)>
    libsamplerate-0.1.8-alt1
  Требует: <libsndfile.so.1()(64bit)>
    libsndfile-1.0.25-alt1.1
  Требует: <libsndfile.so.1(libsndfile.so.1.0)(64bit)>
    libsndfile-1.0.25-alt1.1
  Требует: <libstdc++.so.6(CXXABI_1.3)(64bit)>
    libstdc++6-4.7.2-alt7
  Требует: <libstdc++.so.6(GLIBCXX_3.4)(64bit)>
    libstdc++6-4.7.2-alt7
  Требует: <libtag.so.1()(64bit)>
    libtag-1.8-alt2
  Требует: <libvorbis.so.0()(64bit)>
    libvorbis-1.3.3-alt1
  Требует: <libvorbisenc.so.2()(64bit)>
    libvorbis-1.3.3-alt1
  Требует: <libvorbisfile.so.3()(64bit)>
    libvorbis-1.3.3-alt1
  Требует: <rtld(GNU_HASH)>
    glibc-core-6:2.17-alt8
Когда я только только пробовал переходить на линукс, году в 2007, k3b была частью системы (сидел под kde3 только не помню, какая была тогда версия кед. Помню только дистрибутив: ALTLinux 4.0).

Так что отделять k3b от TDE (форк 3 кед) не стоит.
« Последнее редактирование: 30.10.2015 12:52:35 от Инфлэйм »

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 576
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: k3b
« Ответ #5 : 30.10.2015 13:06:14 »
TDE разве не kdelibs использует?
TDE использует kdelibs 3-й версии, а KDE - kdelibs 4-й версии

Оффлайн Koi

  • Мастер
  • ***
  • Сообщений: 1 381
  • валар дохаэрис
    • Канал на youtube
Re: k3b
« Ответ #6 : 30.10.2015 13:34:43 »
Так что отделять k3b от TDE (форк 3 кед) не стоит.
Так ведь KDE4 и TDE стоят параллельно, ну то есть из kdm можно загрузится в режим kde3, там вовремя загрузки окно приветствия TDE.
TDE использует kdelibs 3-й версии, а KDE - kdelibs 4-й версии
Ясно, они вместе стоят kdelibs и kde4libs не заметил слона называется.
Дополнил описание.
« Последнее редактирование: 30.10.2015 13:56:12 от Koi »

Инфлэйм

  • Гость
Re: k3b
« Ответ #7 : 30.10.2015 14:10:39 »
Для среды TDE есть пакет отдельный пакет k3b.
Малюсенькая стилистическая ошибочка. Пардон.