Автор Тема: Проблема с запуском игры, которой не хватает имеющихся возможностей OpenGL  (Прочитано 2667 раз)

Оффлайн SethWanderer

  • Давно тут
  • **
  • Сообщений: 34
$ sudo apt-get install i586-libGL i586-libGLU i586-xorg-dri-intel
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано i586-libGL.32bit для 'i586-libGL'
Последняя версия i586-libGL.32bit уже установлена.
Выбрано i586-libGLU.32bit для 'i586-libGLU'
Последняя версия i586-libGLU.32bit уже установлена.
Выбрано i586-xorg-dri-intel.32bit для 'i586-xorg-dri-intel'
Последняя версия i586-xorg-dri-intel.32bit уже установлена.
0 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 5 не будет обновлено.

$ sudo apt-get install openGL
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
E: Невозможно найти пакет openGL

у меня 64 битная система

$ lspci -k | grep VGA -A 5
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
Subsystem: Dell Latitude D630
Kernel driver in use: i915
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 0c)
Subsystem: Dell Device 01f9
00:1a.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02)

glxinfo | grep render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
OpenGL renderer string: Mesa DRI Intel(R) 965GM
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_light_max_exponent,
« Последнее редактирование: 18.12.2015 06:30:49 от SethWanderer »

Оффлайн StolbovDV

  • Давно тут
  • **
  • Сообщений: 72
$ sudo apt-get install i586-libGL i586-libGLU i586-xorg-dri-intel
Для установки пакетов используйте synaptic, только обновите индексы пакетной базы. https://www.altlinux.org/Synaptic

Еще приложите вывод команды
$ glxinfo | grep OpenGL

Оффлайн SethWanderer

  • Давно тут
  • **
  • Сообщений: 34
glxinfo | grep render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
OpenGL renderer string: Mesa DRI Intel(R) 965GM
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_light_max_exponent,
[seth@Wanderer-DELL ~]$ glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) 965GM
OpenGL version string: 2.1 Mesa 10.0.5
OpenGL shading language version string: 1.20
OpenGL extensions:

synaptic установлен, допустим открыл я его, и что мне в нём искать?
« Последнее редактирование: 18.12.2015 11:33:39 от SethWanderer »

Оффлайн Hoblin

  • Давно тут
  • **
  • Сообщений: 32
    • Email
А в чём исходная проблема? Я увидел только вывод об отсутствии пакета openGL. Так это не ошибка, его действительно нет, пакет называется libGL и, судя по логу, он установлен и в 64, и в 32 битной версиях.

Оффлайн SethWanderer

  • Давно тут
  • **
  • Сообщений: 34
приложены 2 картинки ошибок
главное в Windows XP всё это работает, а тут не работает.

Инфлэйм

  • Гость
А какой у вас wine? И какая у него разрядность?
rpm -qa | grep wine

Инфлэйм

  • Гость
приложены 2 картинки ошибок
Скриншоты - это хорошо, но для просмотра будет удобнее, если будете копировать вывод терминала и вставлять на форум как текст. С телефона не очень разгонишься посмотреть картинки.

Оффлайн SethWanderer

  • Давно тут
  • **
  • Сообщений: 34
rpm -qa | grep wine
wine-gecko-2.40-alt0.M70P.1
libwine-vanilla-gl-1.8.0-alt0.M70P.1
libwine-vanilla-twain-1.8.0-alt0.M70P.1
i586-wine-vanilla-1.8.0-alt0.M70P.1
i586-libwine-vanilla-1.8.0-alt0.M70P.1
i586-libwine-vanilla-gl-1.8.0-alt0.M70P.1
libwine-vanilla-1.8.0-alt0.M70P.1
i586-libwine-vanilla-twain-1.8.0-alt0.M70P.1

C окошка ошибки текст не скопировать, пробую переписать руками, за опечатки прошу извинить.

1.
Planetary Annihilation Error
It appears that graphic drivers and/or hardware are missing critical OpenGL capabilities.
If this error persists after updating drivers and confirming that your hardware supports OpenGL 3.2, please contact support@uberent.com for additional help.
Error details: Unable to start graphics system: Could not create GL context.

2.
Error
Spacebase DF9 can't run because required OpenGL faetures aren't available.
Make sure the latest graphics card drivers are installed.

пока переписывал понял что нет драйверов на видюху, хотя английского не знаю вовсе, на частично текст понял, как правильно через консоль узнать какая видюха и как на неё поставить драйвера? понимаю что данный вопрос не из этой темы уже, но раз уж тут начал (из-за упоминания про OpenGL в тексте ошибок) может и тут помогут?

lspci -vnn | grep -i VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 0c) (prog-if 00 [VGA controller])


$ cd intel-gfx-installer-for-linux_1.2.1
intel-gfx-installer-for-linux_1.2.1]$ ./bootstrap
bash: ./bootstrap: Нет такого файла или каталога
intel-gfx-installer-for-linux_1.2.1]$ ./bootstrap.sh
bash: ./bootstrap.sh: Нет такого файла или каталога
intel-gfx-installer-for-linux_1.2.1]$ aclocal
intel-gfx-installer-for-linux_1.2.1]$ autoheader
intel-gfx-installer-for-linux_1.2.1]$ automake --gnu -add-missing --copy --foreign
automake-default: unrecognized option `-dd-missing'.
automake-default: Try `/usr/bin/automake-default --help' for more information.
intel-gfx-installer-for-linux_1.2.1]$ autoconf -f -Wall
configure.ac:9: warning: The macro `AM_CONFIG_HEADER' is obsolete.
configure.ac:9: You should run autoupdate.
aclocal.m4:9190: AM_CONFIG_HEADER is expanded from...
configure.ac:9: the top level
configure.ac:14: warning: The macro `AC_GNU_SOURCE' is obsolete.
configure.ac:14: You should run autoupdate.
../../lib/autoconf/specific.m4:297: AC_GNU_SOURCE is expanded from...
configure.ac:14: the top level
configure.ac:19: warning: The macro `AC_PROG_LIBTOOL' is obsolete.
configure.ac:19: You should run autoupdate.
aclocal.m4:129: AC_PROG_LIBTOOL is expanded from...
configure.ac:19: the top level
configure.ac:140: warning: AC_OUTPUT should be used without arguments.
configure.ac:140: You should run autoupdate.
$ ./configure
configure: error: cannot find install-sh, install.sh, or shtool in "." "./.." "./../.."

« Последнее редактирование: 18.12.2015 13:55:57 от SethWanderer »

Инфлэйм

  • Гость
понял что нет драйверов на видюху
Дрова то есть, да только
Spacebase DF9 can't run because required OpenGL faetures aren't available.
Некоторый функционал нужный для игрушки в текущем OpenGL не работает.

$ ./configure
Это не самый лучший выбор. Вот тут неплохо говорится о том, почему не нужно заниматься самодеятельностью с компиляцией программ и дров.
У вас дистрибутив на р7? Возможно OpenGL, который в сизифе будет в самый раз. Не призываю вас переезжать на сизиф, для вас это будет еще то приключение, но почему бы не отписаться в багзилле с просьбой перенести OpenGLиз сизифа в р7.
Ну и
в Windows XP всё это работает
Так что не всё так уж и плохо  ;-)

Оффлайн SethWanderer

  • Давно тут
  • **
  • Сообщений: 34
На счёт компеляции я понял, с моим опытом пока лучше не компилировать, а пользовать пакеты...
А вот на счёт сизифа слышу в первые но заинтересовался :)
да платформа 7

Оффлайн sb

  • Мастер
  • ***
  • Сообщений: 8 083
  • Кто ищет, тот найдёт.
    • убежищесофта.рф
Intel Corporation Mobile GM965/GL960
Боюсь, что с такой карточкой даже сизиф не поможет. В таких случаях действительно лучше использовать винду (тем более, если она имеется второй системой).

Оффлайн SethWanderer

  • Давно тут
  • **
  • Сообщений: 34
В таких случаях действительно лучше использовать винду (тем более, если она имеется второй системой).
Жаль что это не является решением, задам этот же вопрос через пол года, вдруг появятся компетентные специалисты способные помочь в решении этого вопроса. Задача не сменить систему, а настроить альт линукс так чтоб заработало.

Оффлайн sb

  • Мастер
  • ***
  • Сообщений: 8 083
  • Кто ищет, тот найдёт.
    • убежищесофта.рф
задам этот же вопрос через пол года, вдруг появятся компетентные специалисты способные помочь в решении этого вопроса
Вам надо обратиться к специлистам из интела, которые пишут драйвера к вашей карточке или поинтересоваться в интернете (лучше у гугла), поддерживается ли драйвером вашей карточки то, что требует игра. Вряд ли вы найдете здесь кого-то компетентнее специлистов от инетел (в плане поддержки драйвером тех или иных возможностей opengl).
Задача не сменить систему, а настроить альт линукс так чтоб заработало.
В вашем случае все на 100% упирается в возможности драйвера (при условии поддержки нужных возможностей opengl самим графическим чипом). А в винде все через директх работает, поэтому и расклады там другие (впрочем, как и с драйвером и его поддержкой).
« Последнее редактирование: 21.12.2015 11:05:48 от sb »

Оффлайн SethWanderer

  • Давно тут
  • **
  • Сообщений: 34
Спасибо за всестороннее рассмотрение вопроса, продолжу поиск решения, в плоть до написания драйвера и подходящего OpenGL хотя сам в программировании пока что ноль.

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 2 519
  • antohami@
Подождите. У вас я так понимаю Intel GMA3100. Для Винды драйвер даёт:
Under Windows, the driver supports DirectX 10.0,[10][11] Shader Model 4.0 and OpenGL 1.5
Для Линукс:
Under Linux, OpenGL 2.1 is supported.

То есть про шейдеры умалчивается.

В системных требованиях игры указано только, что игра обязательно требует Shader Model 3.0. Но эта игра (Planetary Annihilation) есть в версии для Линукс же! Так давайте линукс-версию пробовать, нафига вам wine сдался? Мне кажется линукс-версия обязана запуститься.