Автор Тема: Падения LibreOffice на p8 при открытии/сохранении файлов.  (Прочитано 739 раз)

Оффлайн ASte

  • Мастер
  • ***
  • Сообщений: 1 383
Поимел в некоторый момент времени на p8  проблему с постоянным падением LibreOffice при открытии/сохранении файлов. Причем только на одном ноутбуке. На втором - все нормально. Оба обновлены до p8 из сизифа.
В констоли - руганть по поводу gtk3
Гугление подсказало таблетку -
declare -x SAL_USE_VCLPLUGIN="gtk"

После "лечения" падения прекратились.







Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Это-бы в багзилу.

Оффлайн ASte

  • Мастер
  • ***
  • Сообщений: 1 383
Хм... На 2-х системах воспроизводится, на одной - не воспроизводится.
Все три системы - обновленв до p8 из сизифа.
Подозреваю какого-то пакета может не хватать...
Сейчас мы их проверим, сейчас мы их сравним (с)...
« Последнее редактирование: 27.05.2016 08:17:47 от ASte »

Оффлайн ASte

  • Мастер
  • ***
  • Сообщений: 1 383
Нашел в системе "где не воспроизводится" вот такой пакет:
$apt-cache show gtk3-themes-xfce4                                                                   
Package: gtk3-themes-xfce4                                                                                         
Section: Graphical desktop/XFce                                                                                     
Installed Size: 224428                                                                                             
Maintainer: XFCE Team <xfce@packages.altlinux.org>                                                                 
Version: 3.0.0-alt2                                                                                                 
Pre-Depends: rpmlib(SetVersions), rpmlib(PayloadIsLzma)                                                             
Depends: libc.so.6(GLIBC_2.2.5)(64bit), libcairo.so.2()(64bit) (>= set:mhBeaP4ayBAtG4qHu7IAieU0kWbMxqhDDW9TfpaIxG8AaWgYeNVTCZA0Ct2), libgdk-3.so.0()(64bit) (>= set:nmZ5n1), libglib-2.0.so.0()(64bit) (>= set:onzLx0), libgobject-2.0.so.0()(64bit) (>= set:mjBgbAF5saonRxGMb3Ezepb), libgtk-3.so.0()(64bit) (>= set:pkTz0F0I0UVYLBCcfaBiyRfoiFKdU0hOXcHm6FWoXHcoschHbLQ8DpZ0h), libm.so.6(GLIBC_2.2.5)(64bit), rtld(GNU_HASH)                                                 
Provides: gtk3-themes-xfce4 (= 3.0.0-alt2)                                                                         
Architecture: x86_64         
При этом в репозитории он не находится...

нашлось в p7 но не помогло...
« Последнее редактирование: 27.05.2016 09:00:36 от ASte »

Оффлайн ASte

  • Мастер
  • ***
  • Сообщений: 1 383
По моему бага уже есть:
https://bugzilla.altlinux.org/show_bug.cgi?id=32121
туда и отписался
« Последнее редактирование: 27.05.2016 09:14:39 от ASte »

Онлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 3 101
  • antohami@
По моему бага уже есть:
https://bugzilla.altlinux.org/show_bug.cgi?id=32121
туда и отписался

Продублирую свой ответ в багзилле:
Я падения победил удалением пакета LibreOffice-gnome. Чтобы обойти проблему с диалоговыми окнами выбрал опцию использовать диалоговые окна libreoffice.
А проблема кроется в gtk3, смотреть баг 32120.

Оффлайн ASte

  • Мастер
  • ***
  • Сообщений: 1 383
Ну точно.. На системе где бага не проявляется этого пакета нет, там где проявляется он установлен.