Автор Тема: Служба управления питанием всегда отключена, настройки не действуют  (Прочитано 2503 раз)

Оффлайн kiav

  • Давно тут
  • **
  • Сообщений: 346
    • Email
Проблема в том, что постоянно вырубается монитор при просмотре фильмов. В частности в VLC (2.1.3). Использую KDesktop 7.0.5. На p8/KDE 5 перейти не готов потому, что нет еще релиза дистрибутива. Да и сам переход смогу провести только в новогодние каникулы. Так что актуален именно этот дистрибутив и KDE 4.

До поры, до времени работал совет с форума:
xset s off
xset -dpms

Я поместил эти команды в ~/.xprofile

Но, сейчас они не работают (точнее, перед просмотром фильма их надо запустить снова в консоли). В чем дело не знаю.

Сунулся в настройки KDE по управлению питанием. А они недоступны потому, что "служба управления питанием не запущена". В настройках KDE есть служба "Управление питанием". Запустил, настройки сделал, сохранил. Но они не действуют. Я запретил отключение монитора, но он все равно отключается. Да и служба не запускается сама, после перезагрузки она снова не запущена.

Работаю на ПК (не ноутбук).

Как заставить действовать настройки управления питанием KDE? Или как убедить VLC/Flash не вырубать монитор? Хотя бы при полноэкранном просмотре.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 571
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Установите программу caffeine (мог перепутать буквы ) и запускайте её , когда хотите, чтобы монитор не засыпал.

Оффлайн kiav

  • Давно тут
  • **
  • Сообщений: 346
    • Email
Установите программу caffeine (мог перепутать буквы )
Она у меня установлена, но иногда не справляется со своей задачей (кодеки, субтитры, выбор дорожек, удобная регулировка звука). Это Kaffeine.

запускайте её , когда хотите, чтобы монитор не засыпал.
Вот эту задачу она решает прекрасно.

Но видео с YuoTube (даже не Flash) выкрутасы с проигрывателями не помогут посмотреть. Потому и смотрю в сторону глобальных настроек в ОС/KDE.

Оффлайн ASte

  • Мастер
  • ***
  • Сообщений: 1 361
проверьте еще настройки скринсейвера. Там тоже есть настройка выключения монитора при его срабатывании.

Оффлайн kiav

  • Давно тут
  • **
  • Сообщений: 346
    • Email
Я это нашел только в блокировщиках экрана. Блокировка экрана автоматически у меня отключена. В качестве блокировщика выбран "простой блокировщик" (не хранитель). Так что это не мой случай.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 571
  • Учиться .... Телепатами не рождаются, ими ....
    • Email

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 571
  • Учиться .... Телепатами не рождаются, ими ....
    • Email

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 7 217
  • UNIX System V init
До поры, до времени работал совет с форума:
xset s off
xset -dpms

Я поместил эти команды в ~/.xprofile

Но, сейчас они не работают

Работают :-)

$ ll ~/.xsession.d/
итого 12
drwx------ 40 user user 4096 сен 14 04:31 ../
-rwxr-xr-x  1 user user   30 сен 13 18:52 dpms-ssaver-off
drwx------  2 user user 4096 сен 13 18:51 ./
$ cat ~/.xsession.d/dpms-ssaver-off
#!/bin/bash

xset s off -dpms
$ xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  20
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600
Colors:
  default colormap:  0x22    BlackPixel:  0    WhitePixel:  16777215
Font Path:
  catalogue:/etc/X11/fontpath.d,built-ins
DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Disabled

Не забывайте про перевод строки.
ZX Spectrum 128K
Привет от NM:  # echo -e "\n[device]\nwifi.scan-rand-mac-address=no" >> /etc/NetworkManager/NetworkManager.conf

Инфлэйм

  • Гость
VLC
Cтранно даже это слышать, этот плеер очень даже хорошо берет управление питанием в свои руки, как и smplayer. Вы в настройках самого плеера смотрели, чтобы он подавлял скринсейвер?

Оффлайн kiav

  • Давно тут
  • **
  • Сообщений: 346
    • Email
https://packages.altlinux.org/en/Sisyphus/srpms/caffeine
Спасибо. Костыль помог. Достаточно установки пакета, в автостарт он прописывается сам (/etc/xdg/autostart/caffeine.desktop).

Добавлено: Есть случай отключения экрана при просмотре VLC (полноэкранный режим). Процессы caffeine в системе висят. Так что не панацея это. Пробую запускать его в caffeinate.

Добавлено 2: caffeinate тоже не помог. Почему первый день с caffeine все было хорошо, а потом как-будто его и нет, я не знаю. Разбираться не стоит потому, что это костыль. Нужно копать настройки KDE, системы, VLC. А caffeine я удалил как мусор. Жаль, что он натянул еще три десятка пакетов, от них уже не уйдешь без неоправданных затрат времени.

DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Disabled
У меня тоже самое. Правда, caffeine запущен. Повторная команда `xset s off -dpms`этот вывод не изменила.

Cтранно даже это слышать, этот плеер [VLC] очень даже хорошо берет управление питанием в свои руки, как и smplayer. Вы в настройках самого плеера смотрели, чтобы он подавлял скринсейвер?
Не нашел эти фразы при поиске во "всех настройках": dpms, screen, saver, хранитель. Так что не знаю какие настройки там нужны.

~/.xsession.d/
Это принципиальный путь? ~/.xprofile у меня точно отрабатывает (записана там команда ssh-add).
« Последнее редактирование: 16.09.2016 18:10:18 от kiav »