Автор Тема: Мне не хватает kompozer.  (Прочитано 2624 раз)

Оффлайн Formikulo

  • Давно тут
  • **
  • Сообщений: 28
    • Email
Мне не хватает kompozer.
« : 15.11.2016 23:14:12 »
Мне не хватает kompozer.
Я - новичок в linuxe. Ищу wysiwyg-редактор html. В Википедии пишут, что самый лучший - kompozer. А в репозиториях alta его почему-то нет:-(
« Последнее редактирование: 20.11.2016 10:06:50 от ruslandh »

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 7 994
  • UNIX System V init
Re: Re: Каких пакетов не хватает в ALT Linux
« Ответ #1 : 16.11.2016 02:33:13 »
Мне не хватает kompozer.
Я - новичок в linuxe. Ищу wysiwyg-редактор html. В Википедии пишут, что самый лучший - kompozer. А в репозиториях alta его почему-то нет:-(

Может куда-то сюда стоит посмотреть?
# apt-cache search ^|grep 'bluefish\|kdewebdev-quanta'|head -n2
bluefish - A GTK2 web development application for experienced users
kdewebdev-quanta - Web IDE
Последний, это пакет из TDE (бывший KDE3, - стартеркит tde или sysv-tde).

Также
kdevelop-for-php - PHP Language Plugin for KDevelop/Quanta.

https://ru.wikipedia.org/wiki/Bluefish
https://ru.wikipedia.org/wiki/Quanta_Plus

quanta под kde4 лет 6 назад обсуждали слакварщики:
http://alien.slackbook.org/blog/quanta-plus-for-kde4/

Хотите честно и по большому счёту?
Последние лет 5-6 кодеры в Линукс больше занимаются свистелками и перделками чем прикладным ПО.
« Последнее редактирование: 16.11.2016 02:42:02 от Speccyfighter »
ZX Spectrum 128K
Привет от NM:  # echo -e "\n[device]\nwifi.scan-rand-mac-address=no" >> /etc/NetworkManager/NetworkManager.conf

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 3 173
  • antohami@
Re: Re: Каких пакетов не хватает в ALT Linux
« Ответ #2 : 18.11.2016 13:43:03 »
Мне не хватает kompozer.
Я - новичок в linuxe. Ищу wysiwyg-редактор html. В Википедии пишут, что самый лучший - kompozer. А в репозиториях alta его почему-то нет:-(

Эта программа заброшена, последний релиз в 2011. Ни в одном актуальном репозитории её нет, судя по pkgs.org. Тем не менее под 32 бита программа собрана и доступна для скачивания https://sourceforge.net/projects/kompozer/files/current/0.8b3/linux-i686/kompozer-0.8b3.ru.gcc4.2-i686.tar.gz/download
Скачали -> распаковали -> запускать ./kompozer
Если не запустится, запустите в терминале:
ldd-requires kompozer-binИ установите недостающие зависимости.
« Последнее редактирование: 18.11.2016 13:56:34 от Антон Мидюков »

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 460
Re: Re: Каких пакетов не хватает в ALT Linux
« Ответ #3 : 18.11.2016 22:18:17 »
Мне не хватает kompozer.
Я - новичок в linuxe. Ищу wysiwyg-редактор html. В Википедии пишут, что самый лучший - kompozer. А в репозиториях alta его почему-то нет:-(

Есть :)

Но за работоспособность на более младших дистрах не ручаюсь, но чем черт не шутит...
http://altlinuxclub.ru/repo/Repo_P6/i686/RPMS.hasher/kompozer-0.8-0.4.b3.i686.rpm

Кстати, можно скачать seamonkey и в нем есть composer как в старые добрые времена WEB-1.0 http://ataridogdaze.com/FreeWebsiteNoAds/SeaMonkeyComposerLbl.gif
Но послабже по фичам...
« Последнее редактирование: 18.11.2016 22:21:56 от YYY »

Оффлайн Formikulo

  • Давно тут
  • **
  • Сообщений: 28
    • Email
Re: Re: Каких пакетов не хватает в ALT Linux
« Ответ #4 : 20.11.2016 06:51:04 »
В какую папку надо распаковывать архив?

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 3 173
  • antohami@
Re: Re: Каких пакетов не хватает в ALT Linux
« Ответ #5 : 20.11.2016 08:36:26 »
В какую папку надо распаковывать архив?

Да хоть куда, главное чтоб файловая система не была NTFS или FAT. В свой домашний каталог, например.

Оффлайн Formikulo

  • Давно тут
  • **
  • Сообщений: 28
    • Email
Re: Re: Каких пакетов не хватает в ALT Linux
« Ответ #6 : 20.11.2016 09:39:42 »
Распаковал  в папку /home/kompozer
В терминале запустил команду:
Цитировать
[root@host-100 ~]# ldd-requires kompozer-bin
bash: ldd-requires: команда не найдена

Что-то пошло не так.
Не запускается. Что делать?

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Мне не хватает kompozer.
« Ответ #7 : 20.11.2016 10:09:44 »
Установить

Оффлайн Formikulo

  • Давно тут
  • **
  • Сообщений: 28
    • Email
Re: Мне не хватает kompozer.
« Ответ #8 : 20.11.2016 10:31:58 »
Цитировать
Установить
Что именно надо сделать?

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 6 570
    • Email
Re: Мне не хватает kompozer.
« Ответ #9 : 20.11.2016 10:55:24 »
Что именно надо сделать?
apt-get install ldd-requires
Сноси Винду, переходи на Линукс ! :)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 6 570
    • Email
Re: Мне не хватает kompozer.
« Ответ #10 : 20.11.2016 10:56:20 »
/home/kompozer
Ну и зачем ? Лучше было бы /home/<username>/kompozer/, где <username> ваш пользователь.
Сноси Винду, переходи на Линукс ! :)

Оффлайн Formikulo

  • Давно тут
  • **
  • Сообщений: 28
    • Email
Re: Мне не хватает kompozer.
« Ответ #11 : 20.11.2016 11:02:34 »
После выданных Вами рекомендаций получилось следующее:
Цитировать
[root@host-100 ~]#                                                                                                                                                                 
[root@host-100 ~]# ./kompozer/kompozer-bin                                                                                                                                         
./kompozer/kompozer-bin: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory 


Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Мне не хватает kompozer.
« Ответ #12 : 20.11.2016 11:04:39 »
Код: [Выделить]

ldd-requires kompozer-bin
И установите недостающие зависимости.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Мне не хватает kompozer.
« Ответ #14 : 20.11.2016 11:06:36 »
пакет есть в репозитории:
https://packages.altlinux.org/ru/Sisyphus/srpms/libmozjs