Автор Тема: Мне не хватает kompozer.  (Прочитано 2621 раз)

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 7 994
  • UNIX System V init
Re: Мне не хватает kompozer.
« Ответ #30 : 20.11.2016 17:10:13 »
Обязательно брать альфа-сборку xfce-sysv?

Нет, не обязательно.
На сизифе, на котором пробно проводилась установка kompozer, все зависимости для клубного rpm-пакета kompozer удовлетворены. Вряд ли в p8 будет сильно по-другому. Для p7 проверять вручную зависимости через elinks и rpm по версиям пакетов, мне честно говоря неохота. Может тоже заработает, а там кто его знает, мало ли что...
Можете брать стартеркит xfce p8 с systemd или сизифную регулярку xfce с systemd, - теперешний сизиф довольно стабилен. Но по сыстемд будут подсказывать другие, - я не оказываю помощь по systemd.
И не потому что не хочу.
Чтобы оказать помощь качественно, нужно всю его архитектуру вместе с фишками и косяками удержать в голове. А удерживать в памяти карточный домик выстроенный из сотни карточных колод, у меня желание меньше нуля. А поскольку сам не пользуюсь systemd, это желание при нулевом стимуле ещё меньше.

Стартеркиты p8
http://ftp.altlinux.org/pub/distributions/ALTLinux/p8/images/starterkits/
Сизифные регулярки
http://nightly.altlinux.org/sisyphus/current/
« Последнее редактирование: 20.11.2016 19:23:09 от Speccyfighter »
ZX Spectrum 128K
Привет от NM:  # echo -e "\n[device]\nwifi.scan-rand-mac-address=no" >> /etc/NetworkManager/NetworkManager.conf

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 7 994
  • UNIX System V init
Re: Мне не хватает kompozer.
« Ответ #31 : 20.11.2016 17:23:45 »
Так что же делать? Ведь раньше kompozer в репозиториях был. Кажется для 4-й платформы

А шо ви таки хотели? :-)
1. Альты не поддерживают пакеты поддержка кода которых прекращена.
И не стоит сильно обольщаться: в осыстемдяченом Дебьян не так давно из репозитория выбросили изрядное количество мёртвых пакетов, а количество нерализованых хотелок исчисляется сотнями, если не перевалило за тысячу.
2. С бранча комьюнити 5.1, количество пакетов увеличилось приблизительно вдвое, а количество мейнтейнеров стоит на месте.
3. Количество желающих новых пакетов растёт в геометрической прогрессии, а количество желающих сказать НА растёт медленно.
4. Я уже предлагал реанимировать backports для таких случаев, когда кто-то не хочет поддерживать пакет, но разовую сборку собрать в backports мог бы. Альты не услышали. Ну нет, и нет, - в конце-концов это не моя проблема.
ZX Spectrum 128K
Привет от NM:  # echo -e "\n[device]\nwifi.scan-rand-mac-address=no" >> /etc/NetworkManager/NetworkManager.conf

Оффлайн Formikulo

  • Давно тут
  • **
  • Сообщений: 28
    • Email
Re: Мне не хватает kompozer.
« Ответ #32 : 20.11.2016 19:27:01 »
Да, понял. Quanta Plus - это наше всё.

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 6 712
  • Sunny 273 RUS crew
Re: Мне не хватает kompozer.
« Ответ #33 : 20.11.2016 20:16:18 »
$ uname -a
Linux host-100.localdomain 3.14.41-std-def-alt1 #1 SMP Thu May 7 12:49:36 UTC 2015 x86_64 GNU/Linux
$ file kompozer
kompozer: directory
Про file Вас ниже поправили. Если у Вас, как и у berkut_174, пишет "ELF 32-bit LSB executable", а не "ELF 64-bit LSB executable", то всё правильно. Приложение 32-разрядное, а система у Вас 64-разрядная. Соответственно, надо ставить не libGL, а i586-libGL, если оно собрано, конечно. Но должно бы. И у Вас должен быть подключен соответствующий репозиторий. apt-repo что показывает ? Если утилиты нет, установите.

Оффлайн Formikulo

  • Давно тут
  • **
  • Сообщений: 28
    • Email
Re: Мне не хватает kompozer.
« Ответ #34 : 20.11.2016 21:58:33 »
Посмотрел в синаптике. такая библиотека у меня уже установлена

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 6 712
  • Sunny 273 RUS crew
Re: Мне не хватает kompozer.
« Ответ #35 : 20.11.2016 22:15:19 »
Посмотрел в синаптике. такая библиотека у меня уже установлена
Именно i586 ? лучше вывод "rpm -qa|grep libGL" покажите.

Оффлайн Formikulo

  • Давно тут
  • **
  • Сообщений: 28
    • Email
Re: Мне не хватает kompozer.
« Ответ #36 : 20.11.2016 23:09:19 »
Цитировать
[user@host-100 ~]$ rpm -qa|grep libGL
i586-libGLU-9.0.0-alt1
libGLee-5.4.0-alt1_3
libGLU-9.0.0-alt1
libGL-10.0.5-alt0.M70P.2
i586-libGLee-5.4.0-alt1_3
libGLU-devel-9.0.0-alt1
i586-libGLU-devel-9.0.0-alt1
i586-libGL-10.0.5-alt0.M70P.2
libGLES-10.0.5-alt0.M70P.2
i586-libGLES-10.0.5-alt0.M70P.2
libGL-devel-10.0.5-alt0.M70P.2
i586-libGL-devel-10.0.5-alt0.M70P.2

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Мне не хватает kompozer.
« Ответ #37 : 20.11.2016 23:22:28 »
i586-libGL - у вас не установлена.

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 6 712
  • Sunny 273 RUS crew
Re: Мне не хватает kompozer.
« Ответ #38 : 21.11.2016 00:04:16 »
i586-libGL - у вас не установлена.
Есть она у него: i586-libGL-10.0.5-alt0.M70P.2

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 7 994
  • UNIX System V init
Re: Мне не хватает kompozer.
« Ответ #39 : 21.11.2016 01:09:38 »
libxpcom.so libxpcom_core.so
Но их в репо нет.

Библиотеки libxpcom* содержит rpm-пакет kompozer, ссылку на который дал YYY:
$ find /usr/lib/ -name "*libxpcom*" 2>/dev/null
/usr/lib/kompozer/libxpcom_core.so
/usr/lib/kompozer/components/libxpcom_compat_c.so
/usr/lib/kompozer/libxpcom.so
/usr/lib/kompozer/libxpcom_compat.so
$ rpm -qf $(find /usr/lib/ -name "*libxpcom*" 2>/dev/null)
kompozer-0.8-0.4.b3
kompozer-0.8-0.4.b3
kompozer-0.8-0.4.b3
kompozer-0.8-0.4.b3

Если что:
http://altlinuxclub.ru/repo/Repo_P6/SRPMS.hasher/kompozer-0.8-0.4.b3.src.rpm
http://altlinuxclub.ru/repo/Repo_P6/i686/RPMS.hasher/kompozer-0.8-0.4.b3.i686.rpm
« Последнее редактирование: 21.11.2016 01:43:07 от Speccyfighter »
ZX Spectrum 128K
Привет от NM:  # echo -e "\n[device]\nwifi.scan-rand-mac-address=no" >> /etc/NetworkManager/NetworkManager.conf

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 7 994
  • UNIX System V init
Re: Мне не хватает kompozer.
« Ответ #40 : 21.11.2016 02:14:23 »
$ ldd-requires kompozer-bin
32 битный файл
У вас 64 битная ОС
Список отсутствующих библиотек:
libmozjs.so libxpcom.so libxpcom_core.so libgtk-x11-2.0.so.0 libgdk-x11-2.0.so.0 libatk-1.0.so.0 libpangocairo-1.0.so.0 libpango-1.0.so.0 libcairo.so.2
Идёт поиск пакетов, которые содержат запрашиваемые библиотеки
Это может занять длительное время
i586-newmoon
i586-libgtk+2
i586-libgtk+2
i586-libatk
i586-libpango
i586-libpango
i586-libcairo
Пожалуйста установите пакеты:
apt-get install i586-newmoon i586-libgtk+2 i586-libgtk+2 i586-libatk i586-libpango i586-libpango i586-libcairo
Следующих библиотек нет в репозитории:
libxpcom.so libxpcom_core.so

Я бы не сильно доверял этой проверке.

Есть проверка на наличие библиотек в репозитории
$ ldd-requires /usr/lib/kompozer/kompozer-bin
Архитектура двоичного файла соответствует ОС
Список отсутствующих библиотек:
libmozjs.so libxpcom_core.so
Идёт поиск пакетов, которые содержат запрашиваемые библиотеки
Это может занять длительное время
newmoon
Пожалуйста установите пакеты:
apt-get install newmoon
Следующих библиотек нет в репозитории:
libxpcom_core.so

но нет проверки на наличие библиотек в самом установленном rpm-пакете kompozer, который не входит в репозиторий
$ ls -R /usr/lib/kompozer/| grep libxpcom
libxpcom_compat.so
libxpcom_core.so
libxpcom.so
libxpcom_compat_c.so

ldd-requires говорит что работать rpm-пакет kompozer не будет, бинарник kompozer-bin rpm-пакета, говорит что будет, - ldd-requires немного приврал:
$ kompozer
Выход из программы:
$ Выход из программы:
bash: Выход: команда не найдена
$ _
Как утверждает bash, запуск и выход из программы kompozer без ошибок.

Да и в отношении libmozjs.so, ldd-requires тоже приврал, - совершенно очевидно, какая библиотека какому установленному пакету принадлежит:
$ find /usr/lib -name "*libmozjs.so*" 2>/dev/null
/usr/lib/kompozer/libmozjs.so
/usr/lib/newmoon/libmozjs.so
« Последнее редактирование: 21.11.2016 02:25:30 от Speccyfighter »
ZX Spectrum 128K
Привет от NM:  # echo -e "\n[device]\nwifi.scan-rand-mac-address=no" >> /etc/NetworkManager/NetworkManager.conf

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 7 994
  • UNIX System V init
Re: Мне не хватает kompozer.
« Ответ #41 : 21.11.2016 03:24:40 »
C kompozer есть и нюанс:
- Ни такого адреса, ни такого расширения у сайта mozilla нет, - см. скриншот.
ZX Spectrum 128K
Привет от NM:  # echo -e "\n[device]\nwifi.scan-rand-mac-address=no" >> /etc/NetworkManager/NetworkManager.conf

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 3 173
  • antohami@
Re: Мне не хватает kompozer.
« Ответ #42 : 21.11.2016 03:35:29 »
Есть проверка на наличие библиотек в репозитории

По третьему кругу это ему объясняем!!!

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 3 173
  • antohami@
Re: Мне не хватает kompozer.
« Ответ #43 : 21.11.2016 03:41:42 »
Да и в отношении libmozjs.so, ldd-requires тоже приврал, - совершенно очевидно, какая библиотека какому установленному пакету принадлежит:

Естественно, через apt-cache search ищет. Если есть предложения по улучшению алгоритма, то велкам: https://forum.altlinux.org/index.php?topic=34812.0

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 460
Re: Мне не хватает kompozer.
« Ответ #44 : 21.11.2016 20:02:43 »
Да, понял. Quanta Plus - это наше всё.

Ну блин.
Установить можно выполнив 2 (ДВЕ) команды...
Проверил на p8 i586 - работает

Выполните от root (su -)
wget -O /tmp/kompozer-0.8-0.4.b3.i686.rpm http://altlinuxclub.ru/repo/Repo_P6/i686/RPMS.hasher/kompozer-0.8-0.4.b3.i686.rpm; apt-get install /tmp/kompozer-0.8-0.4.b3.i686.rpm

и все...