Автор Тема: Мне не хватает kompozer.  (Прочитано 2514 раз)

Оффлайн Formikulo

  • Давно тут
  • **
  • Сообщений: 28
    • Email
Re: Мне не хватает kompozer.
« Ответ #45 : 22.11.2016 02:17:16 »
Попробовал все варианты, пока ничего не помогает.
Может быть kompozer не запускается в 64-битной системе?

Не подскажете с чего начинать изучать Alt Linux?
Похоже, придется капитально учиться

Оффлайн Formikulo

  • Давно тут
  • **
  • Сообщений: 28
    • Email
Re: Мне не хватает kompozer.
« Ответ #46 : 22.11.2016 02:25:18 »
Еще один небольшой вопрос немного на другую тему.
Установил bluefish.
Под user не запускается, в терминале пишет следующее:
Цитировать
[user@host-100 ~]$ bluefish
error reading list 1 Произошла ошибка при открытии файла: Нет такого файла или каталога

** (bluefish:8227): WARNING **: no configfile rcfile-2.0, try to convert config files from older versions

config file migration error 1:Произошла ошибка при открытии файла: Нет такого файла или каталогаerror reading list 1 Произошла ошибка при открытии файла: Нет такого файла или каталога

(bluefish:8227): GLib-ERROR **: gmem.c:165: failed to allocate 18446744073696486690 bytes
Ловушка трассировки/останова

Но запускается после ввода следующей строки:
Цитировать
[user@host-100 ~]$ su-
Password:
[root@host-100 ~]# bluefish
error reading list 1 Произошла ошибка при открытии файла: Нет такого файла или каталога

** (bluefish:8274): WARNING **: no configfile rcfile-2.0, try to convert config files from older versions

config file migration error 1:Произошла ошибка при открытии файла: Нет такого файла или каталогаerror reading list 1 Произошла ошибка при открытии файла: Нет такого файла или каталога
cleanup_scanner, memory scancache 0(0Kb+0Kb) found 0(0Kb) fcontext 0(0Kb) = 0Kb
error: line 2645: multiple definitions of an affix flag
error: line 2653: multiple definitions of an affix flag
error: line 2751: multiple definitions of an affix flag
error: line 2777: multiple definitions of an affix flag
error: line 2915: multiple definitions of an affix flag
error: line 3015: multiple definitions of an affix flag
error: line 3541: multiple definitions of an affix flag
error: line 3793: multiple definitions of an affix flag
error: line 4155: multiple definitions of an affix flag
error: line 4205: multiple definitions of an affix flag
error: line 4387: multiple definitions of an affix flag
error: line 4433: multiple definitions of an affix flag
error: line 5183: multiple definitions of an affix flag
error: line 5513: multiple definitions of an affix flag
error: line 5899: multiple definitions of an affix flag
error: line 5961: multiple definitions of an affix flag
error: line 6163: multiple definitions of an affix flag
error: line 6213: multiple definitions of an affix flag
error: line 6291: multiple definitions of an affix flag
error: line 6381: multiple definitions of an affix flag
error: line 6550: multiple definitions of an affix flag                                                             
error: line 6823: multiple definitions of an affix flag                                                             
                                                                                                                     
(bluefish:8274): Gtk-CRITICAL **: gtk_tree_path_get_depth: assertion `path != NULL' failed

(bluefish:8274): Gtk-CRITICAL **: gtk_tree_path_get_depth: assertion `path != NULL' failed

Как исправить? Не хочется каждый раз его под root запускать

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 459
Re: Мне не хватает kompozer.
« Ответ #47 : 22.11.2016 04:09:57 »
Попробовал все варианты, пока ничего не помогает.
Может быть kompozer не запускается в 64-битной системе?

Ну дак приведите как оно ругается :)
Точно будет видно :)

Установил bluefish.
Как исправить? Не хочется каждый раз его под root запускать

Это из репозитория так себя ведет?

На p8 i586 из реп устанавливается и из под юзера работает.
Ругань, конечно тоже есть,
$ bluefish
error reading list 1 Произошла ошибка при открытии файла: Нет такого файла или каталога

** (bluefish:6012): WARNING **: no configfile rcfile-2.0, try to convert config files from older versions

config file migration error while reading old file 1:Произошла ошибка при открытии файла: Нет такого файла или каталога
error reading list 1 Произошла ошибка при открытии файла: Нет такого файла или каталога

(bluefish:6012): GLib-GObject-WARNING **: The property GtkSettings:gtk-menu-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

(bluefish:6012): GLib-GObject-WARNING **: The property GtkToolButton:stock-id is deprecated and shouldn't be used anymore. It will be removed in a future version.

(bluefish:6012): GLib-GObject-WARNING **: The property GtkSettings:gtk-can-change-accels is deprecated and shouldn't be used anymore. It will be removed in a future version.

но в пределах нормы :)

Надо ждать еще кто сможет bluefish на x64 проверить...
« Последнее редактирование: 22.11.2016 04:26:08 от YYY »

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 3 101
  • antohami@
Re: Мне не хватает kompozer.
« Ответ #48 : 22.11.2016 04:38:03 »
** (bluefish:8227): WARNING **: no configfile rcfile-2.0, try to convert config files from older versions

config file migration error 1:Произошла ошибка при открытии файла: Нет такого файла или каталогаerror reading list 1 Произошла ошибка при открытии файла: Нет такого файла или каталога

Удалите старый конфиг:
rm -fR ~/.bluefish

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 3 101
  • antohami@
Re: Мне не хватает kompozer.
« Ответ #49 : 22.11.2016 04:38:27 »
Надо ждать еще кто сможет bluefish на x64 проверить...

Работает.

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 3 101
  • antohami@
Re: Мне не хватает kompozer.
« Ответ #50 : 22.11.2016 04:41:33 »
Попробовал все варианты, пока ничего не помогает.
Может быть kompozer не запускается в 64-битной системе?

Вы нам свои действия описывайте и выхлоп терминала кидайте, тогда подскажем в чём дело. Оба решения, предлагаемые вам, рабочие. Что-то вы не так делаете.

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 7 980
  • UNIX System V init
Re: Мне не хватает kompozer.
« Ответ #51 : 22.11.2016 04:51:53 »
Может быть kompozer не запускается в 64-битной системе?

kompozer это 32бит приложение которому по зависимостям нужны какие-то i586-* пакеты.
В известном смысле, i586-* пакеты, это костыль позволяющий работать 32бит приложению в 64бит системе.

Не подскажете с чего начинать изучать Alt Linux?

С понимания структуры файловой системы
https://docs.altlinux.org/ru-RU/archive/2.4/html-single/master/alt-docs-master/ch03s02.html#id2514655
и с понимания: что такое зависимости
https://docs.altlinux.org/ru-RU/archive/2.4/html-single/master/alt-docs-master/ch06s06.html#id2534766
У вас здесь просто гигантский пробел.
« Последнее редактирование: 22.11.2016 04:54:12 от Speccyfighter »
ZX Spectrum 128K
Привет от NM:  # echo -e "\n[device]\nwifi.scan-rand-mac-address=no" >> /etc/NetworkManager/NetworkManager.conf

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 3 101
  • antohami@
Re: Мне не хватает kompozer.
« Ответ #52 : 22.11.2016 05:02:06 »
cleanup_scanner, memory scancache 0(0Kb+0Kb) found 0(0Kb) fcontext 0(0Kb) = 0Kb

Аналогичная вашей проблема: https://ubuntuforums.org/showthread.php?t=2220540

Я так понял там пришли к выводу, что беда в правах доступа к файлам в вашем домашнем каталоге. В частности, что нам скажет:
ls -l ~/.local/share/recently-used.xbel

Оффлайн Formikulo

  • Давно тут
  • **
  • Сообщений: 28
    • Email
Re: Мне не хватает kompozer.
« Ответ #53 : 22.11.2016 05:51:39 »
Удалите старый конфиг:
Код: [Выделить]

rm -fR ~/.bluefish
Спасибо, помогло!

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 546
  • Кто ищет, тот найдёт.
    • Email
Re: Мне не хватает kompozer.
« Ответ #54 : 22.11.2016 06:35:11 »
Не подскажете с чего начинать изучать Alt Linux?
Не совсем конкретно по Alt Linux, но по Linux так точно от одного из маинтейнеров Alt Linux https://www.youtube.com/playlist?list=PL387B38E91536055B. В том случае, если вам удобнее переваривать видеовариант.

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 948
Re: Мне не хватает kompozer.
« Ответ #55 : 16.12.2016 00:30:58 »
Попробовал все варианты, пока ничего не помогает.
Может быть kompozer не запускается в 64-битной системе?
64-битная p8. Проверил самый простой способ установки: скачал пакет и сделал даблклик... установился и работает.

Оффлайн Formikulo

  • Давно тут
  • **
  • Сообщений: 28
    • Email
Re: Мне не хватает kompozer.
« Ответ #56 : 22.12.2016 20:39:43 »
Цитировать
64-битная p8. Проверил самый простой способ установки: скачал пакет и сделал даблклик... установился и работает.
Откуда пакет брали?

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 948
Re: Мне не хватает kompozer.
« Ответ #57 : 23.12.2016 13:26:30 »
Цитировать
64-битная p8. Проверил самый простой способ установки: скачал пакет и сделал даблклик... установился и работает.
Откуда пакет брали?
Из клубного репозитория для p6. При установке он еще 1 пакет из текущего репозитория подтянул.

Клубный репозиторий почему-то у меня через раз открываться стал... Интересно, проблемы у моего провайдера или у хостинга?

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 948
Re: Мне не хватает kompozer.
« Ответ #58 : 12.02.2017 16:32:22 »
Система Альт Образование 8.1 x64 с XFCE.

Установил kompozer из клубной репы для p6: http://altlinuxclub.ru/repo/Repo_P6/i686/RPMS.hasher/kompozer-0.8-0.4.b3.i686.rpm

При первом запуске получил:$ kompozer
/usr/lib/kompozer/kompozer-bin: error while loading shared libraries: libplc4.so: cannot open shared object file: No such file or directory
Соответственно, установил запрашиваемую библиотеку:
# apt-get install libplc4.so
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано i586-libnspr.32bit для 'libplc4.so'
Следующие НОВЫЕ пакеты будут установлены:
  i586-libnspr.32bit
0 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 139kB архивов.
После распаковки потребуется дополнительно 343kB дискового пространства.
Получено: 1 http://ftp.altlinux.org p8/branch/x86_64-i586/classic i586-libnspr.32bit 1:4.13.1-alt0.M80P.1 [139kB]
Получено 139kB за 0s (854kB/s).     
Совершаем изменения...
Preparing...                 ################################################################# [100%]
1: i586-libnspr              ################################################################# [100%]
Running /usr/lib/rpm/posttrans-filetriggers
Завершено.

Работает.