Автор Тема: Автовход и энергосбережение в LXDE [решено]  (Прочитано 1405 раз)

Оффлайн Paul.ZS256

  • Давно тут
  • **
  • Сообщений: 112
    • МОУ СОШ им. А.И. Крушанова
Re: Автовход и энергосбережение в LXDE
« Ответ #30 : 03.02.2017 11:47:05 »
судя по всему я совсем разучился настраивать линукс
Не разучились, если сразу лог приложили. :-)

единственно что остается - обновляться.
Ну зачем же сразу сдаваться, тем более, что обновление проблему с гашением экрана не решит точно, да и добавить новых проблем вполне может.

ну лог прикладывать вроде ума много не надо, хотя доброе слово и кошке приятно :)
Про обновления. Семерку (еще Мастер 7.0.0) я устанавливал с своем классе и там они (машинки под р7) работают как часы, а проблемы (ну как проблемы - скорее неприятности) пока на чужих компьютерах, которые были под Школьным Легким Линуксом (когда-то давным-давно устанавливал там 4-ку). Именно на них (чужих машинках) ведется работа по переезду на LXDE

Цитировать
Мне кажется, тогда лучше попробовать использовать менее привередливую секцию "ServerFlags". Если у вас остался созданный файл xorg.conf — удалите его.
ок. убил его и забил на него :)

Цитировать
Файл /etc/X11/xorg.conf.d/10-monitor.conf оставьте, он пригодится (насколько я понял, только с ним одним система загружается у вас нормально).
Создайте файл /etc/X11/xorg.conf.d/11-serverflags.conf со следующим содержимым:
# make for screensaver off
Section "ServerFlags"
    Option "BlankTime" "0"
EndSection


У себя проверил на трёх машинах — так тоже работает.
Такой вариант, если у вас заработает, будет более изящным и универсальным, нежели предложенные ранее.
это попробуем завтра. О результате отпишусь.
« Последнее редактирование: 03.02.2017 11:48:44 от Paul.ZS256 »
Простой учитель из Приморья

Оффлайн Paul.ZS256

  • Давно тут
  • **
  • Сообщений: 112
    • МОУ СОШ им. А.И. Крушанова
о результатах создания 11-serverflags.conf -- не сработало. Почему? не понимаю сам.

но:
И кстати, можно обойтись без создания /etc/X11/xorg.conf, и все поместить в /etc/X11/xorg.conf.d/10-monitor.conf
Будет выглядить так:
....

В свое время брал отсюда: https://wiki.archlinux.org/index.php/Display_Power_Management_Signaling

Этот способ железно сработал. На машинке наконец-то перестал тухнуть экран!
Итак:
1. по автовходу (автологину) в LXDE (6-ка) нужно ставить галку в "Меню">"Настройки">"Администрирование">"Окно входа в систему" (вкладка -- Безопасность)

2. по отключению энергосбережения (огромнейшее спасибо stranger573, dango и всем отклинувшимся!)
  • в папке /etc/X11/xorg.conf.d/ создаем файлик 10-monitor.conf с содержимым

Section "Monitor"
Identifier "Monitor0"
Option "DPMS" "false"
EndSection
Section "ServerLayout"
Identifier "ServerLayout0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"
Option "BlankTime" "0"
EndSection
  • перезапускаем компьютер, наслаждаемся

факт - решено!
Простой учитель из Приморья

Оффлайн dango

  • Мастер
  • ***
  • Сообщений: 1 650
о результатах создания 11-serverflags.conf -- не сработало. Почему? не понимаю сам.
При наличии лога Xorg.0.log разобрались бы. Потому что этот вариант тоже может быть применим.
Если решено - это хорошо :-)
Без фанатизма!
Лучше слов могут быть только дела

Оффлайн Paul.ZS256

  • Давно тут
  • **
  • Сообщений: 112
    • МОУ СОШ им. А.И. Крушанова
Дело в том, что хранить один файлик (и его распечатку) в своем архиве несколько проще :-)
Простой учитель из Приморья