Автор Тема: kipi-plugins ошибка при пакетном ресайзе  (Прочитано 1879 раз)

Оффлайн tema

  • Мастер
  • ***
  • Сообщений: 2 037
    • Email
P8
Если попытаться в gwenview попытаться пакетно поменять размер нескольких фото, то выпадает ошибка:
convert -resize 800x800 -quality 100 -verbose /home/uchitel/144___01/IMG_5158.JPG[0] /home/uchitel/144___01//IMG_5158_1.JPG


convert: unable to open image `/home/uchitel/144___01/IMG_5158.JPG[0]': Нет такого файла или каталога @ error/blob.c/OpenBlob/2705.

convert: no images defined `/home/uchitel/144___01//IMG_5158_1.JPG' @ error/convert.c/ConvertImageCommand/3257.
Очевидно, в скрипте неправильно вызывается convert перепутаны местами источник и результат. Ведь в параметрах сначала указывается какую фото конвертировать, а потом в какой файл, а тут, судя по ошибке, наоборот.
https://bugzilla.altlinux.org/show_bug.cgi?id=33093
« Последнее редактирование: 09.02.2017 13:52:39 от tema »

Оффлайн Spanish ArCher

  • Давно тут
  • **
  • Сообщений: 1 181
У-у-у-пссс!
А где в gwenview пакетная обработка?
У меня как только выделяю несколько файлов все действия над изображениями затеняются. (см. скриншоты во вложениях).

Установлено:
$ rpm -qa | grep kipi
kde5-kipi-plugins-common-5.4.0-alt1.M80P.1
libkf5kipi-16.08.3-alt0.M80P.1
kde5-kipi-plugins-core-5.4.0-alt1.M80P.1
kde5-kipi-plugins-5.4.0-alt1.M80P.1
libkf5kipiplugins5-5.4.0-alt1.M80P.1
kde5-libkipi-common-16.08.3-alt0.M80P.1

$ rpm -qa | grep gwenview
libgwenviewlib5-16.08.3-alt0.M80P.1
kde5-gwenview-16.08.3-alt0.M80P.1
kde5-gwenview-common-16.08.3-alt0.M80P.1

Может чего-то не хватает?
« Последнее редактирование: 09.02.2017 23:06:43 от Spanish ArCher »
Если я попался вам навстречу, Значит вам со мной не по пути.
(С) Воскресение

Оффлайн tema

  • Мастер
  • ***
  • Сообщений: 2 037
    • Email
Может быть...

Оффлайн Spanish ArCher

  • Давно тут
  • **
  • Сообщений: 1 181
А нет у меня такого пункта меню :-(
Если я попался вам навстречу, Значит вам со мной не по пути.
(С) Воскресение

Оффлайн tema

  • Мастер
  • ***
  • Сообщений: 2 037
    • Email
А нет у меня такого пункта меню :-(
Да ещё и по-нерусски всё  :-(

Оффлайн Spanish ArCher

  • Давно тут
  • **
  • Сообщений: 1 181
А нет у меня такого пункта меню :-(
Да ещё и по-нерусски всё  :-(
На любом языке картина одинакова.
LANG=ru_RU.UTF-8
LANG=uk_UA.UTF-8
LANG=C

Для меня нет разницы на каком из этих языков общаться.
Если я попался вам навстречу, Значит вам со мной не по пути.
(С) Воскресение

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email

Оффлайн Spanish ArCher

  • Давно тут
  • **
  • Сообщений: 1 181
Есть два пакета:
http://sisyphus.ru/ru/srpm/Sisyphus/kde4-gwenview
http://sisyphus.ru/ru/srpm/Sisyphus/kde4-kipi-plugins

http://sisyphus.ru/ru/srpm/Sisyphus/kde5-gwenview
http://sisyphus.ru/ru/srpm/Sisyphus/kde5-kipi-plugins

Установлено:

$ rpm -qa | grep kipi
kde5-kipi-plugins-common-5.4.0-alt1.M80P.1
libkf5kipi-16.08.3-alt0.M80P.1
kde5-kipi-plugins-core-5.4.0-alt1.M80P.1
kde5-kipi-plugins-5.4.0-alt1.M80P.1
libkf5kipiplugins5-5.4.0-alt1.M80P.1
kde5-libkipi-common-16.08.3-alt0.M80P.1

$ rpm -qa | grep gwenview
libgwenviewlib5-16.08.3-alt0.M80P.1
kde5-gwenview-16.08.3-alt0.M80P.1
kde5-gwenview-common-16.08.3-alt0.M80P.1

Провел эксперимент. Установил alt-kworkstation-8.1-install-x86_64.iso в виртуалбох. Все делал по дефолту, за исключением выбора групп пакетов - оставил только KDE5, обработка графики и поддержка принтеров. Т.е. убрал эмуляторы, обработку звука и обработку видео.

Результат тот-же = пакетная обработка отсутствует.

P.S. При установке на реальное железо всё делал по дефолту, за исключением выбора языка на экране загрузки (F2). Выбрал украинский.
Если я попался вам навстречу, Значит вам со мной не по пути.
(С) Воскресение

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Так у вас и до этого стоял kde5-gwenview

Оффлайн Spanish ArCher

  • Давно тут
  • **
  • Сообщений: 1 181
Так у вас и до этого стоял kde5-gwenview
Ну да. Из коробки. И kipi.
А вот пакетной обработки нету. :-(

Я думал может что-то сломал. Поэтому и с виртуалбоксом начал тестировать.
Если я попался вам навстречу, Значит вам со мной не по пути.
(С) Воскресение

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Так у вас и до этого стоял kde5-gwenview
Ну да. Из коробки. И kipi.
А вот пакетной обработки нету. :-(

Я думал может что-то сломал. Поэтому и с виртуалбоксом начал тестировать.
Попробуйте kde4-gwenview

Оффлайн Spanish ArCher

  • Давно тут
  • **
  • Сообщений: 1 181
Попробуйте kde4-gwenview

А зачем если у меня KDE5?
kde4-gwenview тянет за собой кучу приблуд из KDE4. Зачем мусорить в системе?
Всегда есть альтернативные варианты.
Например ShowFoto, XnViewMP, да тот же консольный convert.

Оставим это. Может само вылечится :-)
Если я попался вам навстречу, Значит вам со мной не по пути.
(С) Воскресение

Оффлайн tema

  • Мастер
  • ***
  • Сообщений: 2 037
    • Email
Попробуйте kde4-gwenview

А зачем если у меня KDE5?
kde4-gwenview тянет за собой кучу приблуд из KDE4. Зачем мусорить в системе?
Всегда есть альтернативные варианты.
Например ShowFoto, XnViewMP, да тот же консольный convert.

Оставим это. Может само вылечится :-)
А что лучше брать для пакетной обработки под KDE5? У меня учителя с convert не разберутся, а я сейчас стараюсь перевести комету на KDE5

Оффлайн Spanish ArCher

  • Давно тут
  • **
  • Сообщений: 1 181
А что лучше брать для пакетной обработки под KDE5? У меня учителя с convert не разберутся, а я сейчас стараюсь перевести комету на KDE5

Мне нравится XnViewMP. Причем с незапамятных времен, когда я еще виндейцем был.
 http://www.xnview.com/en/xnviewmp/
Скачиваю тарбол. Разворачиваю в opt.
На всякий случай меняю владельца на root.
XnView.desktop копирую (или перемещаю) в /usr/share/applications
Всё.

И русский интерфейс присутствует.
Сейчас у меня версия
XnViewMP Version 0.84 x64 (Jan 17 2017)замечательно работает.
Если я попался вам навстречу, Значит вам со мной не по пути.
(С) Воскресение

Оффлайн tema

  • Мастер
  • ***
  • Сообщений: 2 037
    • Email
Попробовал поставить из репы:
XnViewMP
Version 0.84 x64 (Jan 17 2017)

Libformat version 6.95
Сейчас потестирую. Шрифт очень не нравится  :-(