Автор Тема: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]  (Прочитано 1087 раз)

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 938
Попытка обновления Simply x64 с p8 до Сизифа. Как часто и бывает, в конце получил сообщение об ошибке.

Пытаюсь исправить:
#apt-get -f install
Чтение списков пакетов...
Построение дерева зависимостей...
Исправление зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  liblua5.1
Следующие пакеты будут ОБНОВЛЕНЫ:
  liblua5.1
Следующие пакеты будут ЗАМЕНЕНЫ:
  lua5.1-alt-compat (by liblua5.1)
1 будет обновлено, 0 новых установлено, 1 пакетов будет заменено, 0 пакетов будет удалено и 1 не будет обновлено.
Необходимо получить 0B/86,9kB архивов.
После распаковки будет освобождено 4078B дискового пространства.
Совершаем изменения...
Подготовка...                           ################################# [100%]
файл /usr/lib64/lua/5.1 из устанавливаемого пакета liblua5.1-5.1.5-alt4.x86_64 конфликтует с файлом из пакета lua5.1-alt-compat-1.0-alt1.x86_64
файл /usr/share/lua/5.1 из устанавливаемого пакета liblua5.1-5.1.5-alt4.x86_64 конфликтует с файлом из пакета lua5.1-alt-compat-1.0-alt1.x86_64
E: Ошибка во время исполнения транзакции


При попытке установить недостающую библиотеку:
#apt-get install liblua5.1
Чтение списков пакетов...
Построение дерева зависимостей...
You might want to run `apt-get --fix-broken install' to correct these:
Следующие пакеты имеют неудовлетворенные зависимости:
  liblua5.1: Конфликтует: lua5.1-alt-compat
             Вытесняет: lua5.1-alt-compat
  lua5.1-alt-compat: Требует: /usr/lib64/lua5
                     Требует: /usr/share/lua5
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).

С учетом того, что в логе обновления есть
..............
liblpsolve                   ##################################################
remove lua5.1-alt-compat manually!
lua5.1                       ##################################################
.................
пытаюсь удалить:
#apt-get remove lua5.1-alt-compat
Чтение списков пакетов...
Построение дерева зависимостей...
You might want to run `apt-get --fix-broken install' to correct these:
Следующие пакеты имеют неудовлетворенные зависимости:
  lua5.1: Требует: liblua5.1 (= 5.1.5-alt4)
  luarocks: Требует: /usr/lib64/lua/5.1
            Требует: /usr/share/lua/5.1
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).

В общем, ни назад, ни вперед.

Обновление повторил дважды: ошибка воспроизводится стабильно.
« Последнее редактирование: 12.02.2017 00:03:01 от Dmytro »

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 938
Re: p8->Sisyphus. Проблема с lua 5.1
« Ответ #1 : 10.02.2017 02:13:56 »
Продвинулся после
# rpm -e --nodeps lua5.1-alt-compatдалее
#apt-get install liblua5.1и
#apt-get -f install

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 938
Re: p8->Sisyphus. Проблема с lua 5.1
« Ответ #2 : 10.02.2017 02:38:57 »
В общем, фейл. Ни с новым, ни со старым ядром даже до окна логина не прогружается. В консоль войти можно, но проблемно: каждые 2-5 секунд на первую консоль перекидывает - трудно что-то ввести и прочитать.

Сегодня спать пора... завтра попробую подрубиться снаружи по ssh.

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 938
Re: p8->Sisyphus. Проблема с lua 5.1
« Ответ #3 : 11.02.2017 14:38:40 »
Причины того, что система не грузится, назвать, пока, затрудняюсь. Но уверен, что это не связано с lua.

Информация о проблеме с lua уже есть в Wiki и рассылке
« Последнее редактирование: 11.02.2017 14:40:49 от Dmytro »

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 570
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #4 : 11.02.2017 15:15:39 »
В консоль войти можно, но проблемно: каждые 2-5 секунд на первую консоль перекидывает
Так он пытается X-ы запустить. Видно в карточке проблема.
« Последнее редактирование: 11.02.2017 15:44:22 от ruslandh »

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 17 020
    • Домашняя страница
    • Email
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #5 : 11.02.2017 15:21:37 »
При неудачном запуске X-ов они пытаются запуститься 10 раз. Нужно просто подождать.
Андрей Черепанов (cas@)

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 938
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #6 : 11.02.2017 15:45:47 »
При неудачном запуске X-ов они пытаются запуститься 10 раз. Нужно просто подождать.
Оставлял почти на полчаса... Не помогло.
Так он пытается X-ы запустить. Видно в корточке проблема.
Похоже, проблема в модуле виртуалбокса. Причем, воспроизводится только на ядрах std-def. Сейчас пробую на разных дистрибутивах с разными ядрами и разными вариантами обновления. Постараюсь к вечеру на форум результаты тестов выкинуть.

Предварительно могу дать такой совет: если нужно обновить p8 до сизифа внутри virtualbox, лучше поменять ядро на un-def.

P.S.: Называется, сходил за хлебушком cura из Сизифа попробовать решил... Уже почти неделю вожусь с обновлением p8 до Сизифа, которое то идет, то нет.
« Последнее редактирование: 11.02.2017 21:09:46 от Dmytro »

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 570
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #7 : 11.02.2017 16:04:10 »
Похоже, проблема в модуле виртуалбокса.
А , так это внутри VirtualBox ? Тогда модуль VirtualBox должен соответствовать VirtualBox

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 938
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #8 : 11.02.2017 16:10:22 »
Тогда модуль VirtualBox должен соответствовать VirtualBox
Вы про какой? Если про расширения для VB, то он соответствует версии VB. А я про модуль ядра, который и обеспечивает поддержку графики гостевой системе. Он разве может звисеть от версии VB на хосте?

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 570
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #9 : 11.02.2017 16:23:18 »
Он разве может звисеть от версии VB на хосте?
Да, конечно, зависит от версии VirtualBox - это даже из названия пакета ядра видно.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 570
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #10 : 11.02.2017 16:26:40 »
Например:
https://packages.altlinux.org/ru/Sisyphus/srpms/kernel-modules-virtualbox-addition-std-def
5.1.14-alt1.263216.1 - для VirtualBox 5.1.14 и ядра kernel-image-std-def-4.4.48
« Последнее редактирование: 11.02.2017 16:29:13 от ruslandh »

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 938
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #11 : 11.02.2017 16:31:45 »
Он разве может звисеть от версии VB на хосте?
Да, конечно, зависит от версии VirtualBox - это даже из названия пакета ядра видно.
Спасибо, не знал. Но тогда я совсем ничего не понимаю в работе этого модуля.
Например:
https://packages.altlinux.org/ru/Sisyphus/srpms/kernel-modules-virtualbox-addition-std-def
5.1.14-alt1.263216.1 - для VirtualBox 5.1.14 и ядра kernel-image-std-def-4.4.48
Т.е. на Virtualbox 5.1.10 он работать нормально не может?

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 570
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #12 : 11.02.2017 16:35:58 »
Т.е. на Virtualbox 5.1.10 он работать нормально не может?
Я думаю -нет

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 570
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #13 : 11.02.2017 16:36:46 »
Если только повезёт.

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 938
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #14 : 11.02.2017 16:48:59 »
Т.е. на Virtualbox 5.1.10 он работать нормально не может?
Я думаю -нет
Вы ошибаетесь. Вот пример. Стартеркит XFCE-SysVinit x64, обновленный до Сизифа:$ dmesg | grep vbox
[   31.854823] vboxguest: misc device minor 57, IRQ 20, I/O port d020, MMIO at 00000000f0400000 (size 0x400000)
[   31.854833] vboxguest: Successfully loaded version 5.1.14 (interface 0x00010004)
[   35.964235] fbcon: vboxdrmfb (fb0) is primary device
[   37.980296] vboxvideo 0000:00:02.0: fb0: vboxdrmfb frame buffer device
[   37.980333] [drm] Initialized vboxvideo 1.0.0 20130823 for 0000:00:02.0 on minor 0
Все прекрасно работает.

А вот еще интереснее... Debian 8:
# dmesg | grep vbox
[   10.350971] vboxguest: misc device minor 59, IRQ 20, I/O port d020, MMIO at 00000000f0400000 (size 0x400000)
[   10.350979] vboxguest: Successfully loaded version 4.3.36_Debian (interface 0x00010004)
[   11.271973] [drm] Initialized vboxvideo 1.0.0 20090303 for 0000:00:02.0 on minor 0
[   18.243383] vboxsf: Successfully loaded version 4.3.36_Debian (interface 0x00010004)
Тут модуль, вообще, 4.3.36_DebianИ тоже все работает.