Автор Тема: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]  (Прочитано 1255 раз)

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 955
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #15 : 11.02.2017 16:50:53 »
Насколько помню, в Virtualbox бывали проблемы совместимости... но это были баги.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #16 : 11.02.2017 17:15:11 »
Вы ошибаетесь. Вот пример. Стартеркит XFCE-SysVinit x64, обновленный до Сизифа:
Код: [Выделить]
Это примеры везения ;-)

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 955
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #17 : 11.02.2017 18:04:34 »
Вы ошибаетесь. Вот пример. Стартеркит XFCE-SysVinit x64, обновленный до Сизифа:
Код: [Выделить]
Это примеры везения ;-)
Значит, мне всегда везло  ;-)
Вот еще пример везения:
$ dmesg | grep vbox
[   20.962537] vboxguest: module verification failed: signature and/or required key missing - tainting kernel
[   21.063330] vboxguest: misc device minor 55, IRQ 9, I/O port d040, MMIO at 00000000f0000000 (size 0x400000)
[   21.063340] vboxguest: Successfully loaded version 5.0.32_Ubuntu (interface 0x00010004)
[   21.972458] fbcon: vboxdrmfb (fb0) is primary device
[   23.158344] vboxvideo 0000:00:02.0: fb0: vboxdrmfb frame buffer device
[   23.170563] [drm] Initialized vboxvideo 1.0.0 20130823 for 0000:00:02.0 on minor 0
[   40.309607] vboxsf: Successfully loaded version 5.0.32_Ubuntu (interface 0x00010004)
Все эти виртуалки на 1 хосте с VB 5.1.10

Если модуль нужен той же версии, что и VB, то получается под каждый релиз VB в большинстве дистрибутивов нужно модули руками собирать?

Вы меня заинтриговали, надо порыться в офдокументации.
« Последнее редактирование: 11.02.2017 18:12:29 от Dmytro »

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 955
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #18 : 11.02.2017 22:47:03 »
Возвращаюсь к основной теме. Я так понимаю, разработчики пытались починить конвликт lua5.1... и починили совсем  8-| Из 1 ошибки сделали 2. Теперь после # rpm -e --nodeps lua5.1-alt-compatВыскочила еще 1 ошибка: в системе одновременно оказались liblua5.1-5.1.5-alt1 и liblua5.1-5.1.5-alt7

Далее я сделал глупость:
# rpm -e --nodeps liblua5.1-5.1.5 (вроде, так вводил), после чего удалилась версия, которая liblua5.1-5.1.5-alt7, а осталась ненужная liblua5.1-5.1.5-alt1
Пришлось делать
 # rpm -e --nodeps liblua5.1-5.1.5-alt1
Теперь оказался в тупике, и не знаю, куда дальше двигаться.

# apt-get install liblua5.1
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие НОВЫЕ пакеты будут установлены:
  liblua5.1
0 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 1 не будет обновлено.
Необходимо получить 0B/87,3kB архивов.
После распаковки потребуется дополнительно 195kB дискового пространства.
Совершаем изменения...
Подготовка...                           ################################# [100%]
remove lua5.1-alt-compat manually!
ошибка: %prein(liblua5.1-5.1.5-alt7.x86_64) scriptlet failed, exit status 1
ошибка: liblua5.1-5.1.5-alt7.x86_64: установить failed
E: Произошли ошибки при выполнении транзакции
# apt-get -f install
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Исправление зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  liblua5.1
Следующие НОВЫЕ пакеты будут установлены:
  liblua5.1
0 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 1 не будет обновлено.
Необходимо получить 0B/87,3kB архивов.
После распаковки потребуется дополнительно 195kB дискового пространства.
Продолжить? [Y/n] y
Совершаем изменения...
Подготовка...                           ################################# [100%]
remove lua5.1-alt-compat manually!
ошибка: %prein(liblua5.1-5.1.5-alt7.x86_64) scriptlet failed, exit status 1
ошибка: liblua5.1-5.1.5-alt7.x86_64: установить failed
E: Произошли ошибки при выполнении транзакции
# rpm -e --nodeps lua5.1-alt-compat
ошибка: пакет lua5.1-alt-compat не установлен

Если я правильно понимаю, то установка liblua5.1-5.1.5-alt7 не идет из-за того, что преинстал скрипт пытается удалить lua5.1-alt-compat, которого у меня нет. И как такое исправить? Установить lua5.1-alt-compat? Хорошая шутка от мейнтейнера  :-t


Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 955
Попробовал и такой вариант:
# wget http://ftp.altlinux.org/pub/distributions/archive/p8/date/2017/01/31/x86_64/RPMS.classic/lua5.1-alt-compat-1.0-alt1.x86_64.rpm
--2017-02-11 22:44:42--  http://ftp.altlinux.org/pub/distributions/archive/p8/date/2017/01/31/x86_64/RPMS.classic/lua5.1-alt-compat-1.0-alt1.x86_64.rpm
Распознаётся ftp.altlinux.org… 62.152.55.238
Подключение к ftp.altlinux.org|62.152.55.238|:80... соединение установлено.
HTTP-запрос отправлен. Ожидание ответа… 200 OK
Длина: 2447 (2,4K) [application/x-redhat-package-manager]
Сохранение в: «lua5.1-alt-compat-1.0-alt1.x86_64.rpm»

lua5.1-alt-compat-1 100%[===================>]   2,39K  --.-KB/s    за 0,007s 

2017-02-11 22:44:42 (338 KB/s) - «lua5.1-alt-compat-1.0-alt1.x86_64.rpm» сохранён [2447/2447]

# rpm -i --nodeps lua5.1-alt-compat-1.0-alt1.x86_64.rpm# apt-get -f install
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Исправление зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  liblua5.1
Следующие пакеты будут УДАЛЕНЫ:
  lua5.1-alt-compat
Следующие НОВЫЕ пакеты будут установлены:
  liblua5.1
0 будет обновлено, 1 новых установлено, 1 пакетов будет удалено и 1 не будет обновлено.
Необходимо получить 0B/87,3kB архивов.
После распаковки потребуется дополнительно 195kB дискового пространства.
Продолжить? [Y/n] y
Совершаем изменения...
Подготовка...                           ################################# [100%]
файл /usr/lib64/lua/5.1 из устанавливаемого пакета liblua5.1-5.1.5-alt7.x86_64 конфликтует с файлом из пакета lua5.1-alt-compat-1.0-alt1.x86_64
файл /usr/share/lua/5.1 из устанавливаемого пакета liblua5.1-5.1.5-alt7.x86_64 конфликтует с файлом из пакета lua5.1-alt-compat-1.0-alt1.x86_64
E: Ошибка во время исполнения транзакции

Т.е. когда его нет, не ставится потому, что его нет,  а когда есть, потому, что есть?

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 955
Обратил внимание вот на это:
Подготовка...                           ################################# [100%]
файл /usr/lib64/lua/5.1 из устанавливаемого пакета liblua5.1-5.1.5-alt7.x86_64 конфликтует с файлом из пакета lua5.1-alt-compat-1.0-alt1.x86_64
файл /usr/share/lua/5.1 из устанавливаемого пакета liblua5.1-5.1.5-alt7.x86_64 конфликтует с файлом из пакета lua5.1-alt-compat-1.0-alt1.x86_64
E: Ошибка во время исполнения транзакции

И изучив Spek-:
%pre -n lib%{name}
# ----------- begin update from old lua5 to lua5.1 ----
if [ -L %_libdir/lua/5.1 ]; then
    echo "remove lua5.1-alt-compat manually!"
    exit 1
fi
if [ -d %_libdir/lua5 ] && [ ! -d %_libdir/lua/5.1 ]; then
    mkdir -p %_libdir/lua
    mv %_libdir/lua5 %_libdir/lua/5.1
fi
if [ -L %_datadir/lua/5.1 ]; then
    echo "remove lua5.1-alt-compat manually!"
    exit 1
fi
if [ -d %_datadir/lua5 ] && [ ! -d %_datadir/lua/5.1 ]; then
    mkdir -p %_datadir/lua
    mv %_datadir/lua5 %_datadir/lua/5.1
fi
# ----------- end update from old lua5 to lua5.1 ----
Полез смотреть, что же там лежит. Оказалось.... ссылки!!! на каталоги /usr/lib64/lua5 и /usr/share/lua5 Вот это конфликт.

Снова удалил lua5.1-alt-compat, с ним исчезли ссылки. После этого liblua5.1 стала нормально:# apt-get -f  install
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Исправление зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  liblua5.1
Следующие НОВЫЕ пакеты будут установлены:
  liblua5.1
0 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 1 не будет обновлено.
Необходимо получить 0B/87,3kB архивов.
После распаковки потребуется дополнительно 195kB дискового пространства.
Продолжить? [Y/n] y
Совершаем изменения...
Подготовка...                           ################################# [100%]
Обновление / установка...
1: liblua5.1-5.1.5-alt7                 ################################# [100%]
Завершено.

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 955

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 955
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #22 : 12.02.2017 17:54:59 »
Похоже, проблема в модуле виртуалбокса.
А , так это внутри VirtualBox ? Тогда модуль VirtualBox должен соответствовать VirtualBox
Он разве может звисеть от версии VB на хосте?
Да, конечно, зависит от версии VirtualBox - это даже из названия пакета ядра видно.

Обращаемся к официальному руководству.
https://www.virtualbox.org/manual/ch04.html
Цитировать
4.2.2. Guest Additions for Linux
.....
Note that some Linux distributions already come with all or part of the VirtualBox Guest Additions. You may choose to keep the distribution's version of the Guest Additions but these are often not up to date and limited in functionality, so we recommend replacing them with the Guest Additions that come with VirtualBox. The VirtualBox Linux Guest Additions installer tries to detect existing installation and replace them but depending on how the distribution integrates the Guest Additions, this may require some manual interaction. It is highly recommended to take a snapshot of the virtual machine before replacing pre-installed Guest Additions.
Сказано, что может быть устаревшим или менее функциональным.
Цитировать
4.2.2.1. Installing the Linux Guest Additions

The VirtualBox Guest Additions for Linux are provided on the same virtual CD-ROM file as the Guest Additions for Windows described above. They also come with an installation program guiding you through the setup process, although, due to the significant differences between Linux distributions, installation may be slightly more complex.

Installation generally involves the following steps:

    Before installing the Guest Additions, you will have to prepare your guest system for building external kernel modules. This works similarly as described in Section 2.3.2, “The VirtualBox driver modules”, except that this step must now be performed in your Linux guest instead of on a Linux host system, as described there.
Нет ни слова про привязку к версии VB.

А на https://www.virtualbox.org/manual/ch02.html#externalkernelmodules
Цитировать
2.3.2. The VirtualBox driver modules
...
Рассказывается о том, что при сборке модуля ядра нужы исходники текущего ядра. И, опять же, ни слова про версию VB.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #23 : 12.02.2017 20:20:06 »
Невозможность запуск xorg можно тоже рассматривать, как потерю функциональности :-)

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 955
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #24 : 12.02.2017 20:28:40 »
Руслан, можете, как модератор перенести сообщения, каксающиеся VB (после "завел багу..." в тему https://forum.altlinux.org/index.php?topic=38303.0 ?
Невозможность запуск xorg можно тоже рассматривать, как потерю функциональности
Согласен. Но к описываемому мной случаю это не относится, т.к. если удалить эти дополнения, а потом начать обновлять систему, то результат получается тот же: невозможность запуска x-сервера.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: p8->Sisyphus. Проблема с lua 5.1 [РЕШЕНО]
« Ответ #25 : 13.02.2017 07:42:03 »
невозможность запуска x-сервера.

Кстати, какой видеодрайвер пытается использоваться?