Автор Тема: Воспроизведение видео в разных плеерах  (Прочитано 8174 раз)

Оффлайн Сергей-70

  • Давно тут
  • **
  • Сообщений: 434
Добрый день! Столкнулся с такой проблемой:
На стационарном компьютере плохо проигрываются видеофайлы с расширением MTS (в свойствах файла пишется: "транспортный поток mpeg-2":
в smplayer и vlc изображение фрагментируется, сильно отстает от звука. На этом же компьютере медиаплеер parole показывает все нормально.
Пытался сбросить настройки smplayer и vlc в умолчательные, но ничего не помогает. Нагрузка процессора всегда невысокая, запас по мощности есть.
В это же время на ноуте с более слабым мобильным core i3 vlc показывает все корректно.
Везде стоит Альт, установленный со стартеркита.
Какие настройки vlc и smplayer влияют на отображение?

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 6 896
    • Email
Какие настройки vlc и smplayer влияют на отображение?
Устройство вывода видео ?
Сноси Винду, переходи на Линукс ! :)

Онлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 8 882
  • UNIX System V init
Какие настройки ... и smplayer влияют на отображение?

smplayer:
Двойная буферизация
Допускать выпадение кадров
ZX Spectrum 128K
Привет от NM:  # echo -e "\n[device]\nwifi.scan-rand-mac-address=no" >> /etc/NetworkManager/NetworkManager.conf


Оффлайн ∞lan∞

  • Давно тут
  • **
  • Сообщений: 328
Скачал файл для проверки.
mpv лучше всего использовать. vlc тоже неплох, а вот mplayer не справляется. mplayer воспроизводит этот файл как будто с ускоренной перемоткой.
Короче, если в smplayer в качестве движка выбран mplayer то надо включить на вкладке "дополнительно" опцию "По умолчанию использовать демультиплексор lavf" (см. вложение).
В моем случае так.
« Последнее редактирование: 29.08.2018 12:38:21 от ∞lan∞ »

Оффлайн ∞lan∞

  • Давно тут
  • **
  • Сообщений: 328
Скачал файл для проверки.
mpv лучше всего использовать. vlc тоже неплох, а вот mplayer не справляется. mplayer воспроизводит этот файл как будто с ускоренной перемоткой.
Короче, если в smplayer в качестве движка выбран mplayer то надо включить на вкладке "дополнительно" опцию "По умолчанию использовать демультиплексор lavf" (см. вложение).
В моем случае так.
и ещё так можно
$ mplayer -vo vdpau -vc ffh264vdpau -demuxer lavf "MTS AVCHD Lite files no picture bug since v.2.1.1.MTS"

Оффлайн Сергей-70

  • Давно тут
  • **
  • Сообщений: 434
Огромное спасибо! Начал было отвечать на ваши вопросы про настройки, а вы уже помогли.
Цитировать
если в smplayer в качестве движка выбран mplayer то надо включить на вкладке "дополнительно" опцию "По умолчанию использовать демультиплексор lavf" (см. вложение).
- сразу все заработало нормально.
Думаю тему можно и закрыть