Автор Тема: Переход с автозависимостей пакетов Ruby на указанные в gemspec  (Прочитано 4170 раз)

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 16 998
    • Домашняя страница
    • Email
Сегодня в Sisyphus собрана новая версия rpm-build-ruby и пересобраны пакеты с ней.

Важной особенностью является переход с автозависимостей пакетов Ruby с подключением библиотек, указанные в require на зависимости, которые указаны разработчиками в файле gemspec. Это позволит получить все необходимые пакеты как Gem'ы. Для этого предоставляются и требуются зависимости вида:

ruby-gem(имя_гема)

Для совместимости с Fedora также предоставляется  rubygem(имя_гема).

Для сборки пакета как Gem'а по новой схеме достаточно использовать в секции %install макрос %ruby_install
В секции %files: %rubygem_specdir/*

Технически применяется схема Debian с установкой пакета через доработанный ruby-tool-setup (который указывать явно уже не нужно, он вытягивается rpm-build-ruby), который также устанавливает gemspec и Gemfile. По ним и определяются с помощью ruby-bundler provides и requires.
Андрей Черепанов (cas@)

Онлайн hasculdr

  • Давно тут
  • **
  • Сообщений: 520
Обычному пользователю нужно руку прикладывать, или само обновится как надо?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 16 998
    • Домашняя страница
    • Email
Обычному пользователю нужно руку прикладывать, или само обновится как надо?
Само обновится как надо. Это важнее для мейнтейнеров. А делается для разработчиков на Ruby, чтобы свои песочницы делали из обновляемых пакетов, а не скачивания из Интернета.
Андрей Черепанов (cas@)