Автор Тема: W: В Вашей системе установлено несколько версий пакета "libobasis6.1-core"  (Прочитано 7859 раз)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 6 971
    • Email
Всем привет!

# apt-get update
Получено: 1 ftp://ftp.firma.zn p8/branch/x86_64 release [880B]
Получено: 2 ftp://ftp.firma.zn p8/branch/x86_64-i586 release [537B]
Получено: 3 ftp://ftp.firma.zn p8/branch/noarch release [673B]
Получено 2090B за 0s (14,9kB/s).             
Получено: 1 ftp://ftp.firma.zn p8/branch/x86_64/classic pkglist [20,5MB]
Получено: 2 ftp://ftp.firma.zn p8/branch/x86_64/classic release [135B]
Получено: 3 ftp://ftp.firma.zn p8/branch/x86_64-i586/classic pkglist [15,4MB]
Получено: 4 ftp://ftp.firma.zn p8/branch/x86_64-i586/classic release [140B]
Получено: 5 ftp://ftp.firma.zn p8/branch/noarch/classic pkglist [5090kB]
Получено: 6 ftp://ftp.firma.zn p8/branch/noarch/classic release [135B]
Получено 41,0MB за 5s (7084kB/s).               
error: rpmdb: damaged header instance #2029 retrieved, skipping.
error: rpmdb: damaged header instance #2045 retrieved, skipping.
error: rpmdb: damaged header instance #2042 retrieved, skipping.
error: rpmdb: damaged header instance #2039 retrieved, skipping.
error: rpmdb: damaged header instance #2049 retrieved, skipping.
error: rpmdb: damaged header instance #2036 retrieved, skipping.
error: rpmdb: damaged header instance #2052 retrieved, skipping.
error: rpmdb: damaged header instance #2033 retrieved, skipping.
error: rpmdb: damaged header instance #2041 retrieved, skipping.
error: rpmdb: damaged header instance #2030 retrieved, skipping.
error: rpmdb: damaged header instance #2038 retrieved, skipping.
error: rpmdb: damaged header instance #2046 retrieved, skipping.
error: rpmdb: damaged header instance #2050 retrieved, skipping.
error: rpmdb: damaged header instance #2035 retrieved, skipping.
error: rpmdb: damaged header instance #2043 retrieved, skipping.
error: rpmdb: damaged header instance #2053 retrieved, skipping.
error: rpmdb: damaged header instance #2032 retrieved, skipping.
error: rpmdb: damaged header instance #2040 retrieved, skipping.
error: rpmdb: damaged header instance #2048 retrieved, skipping.
error: rpmdb: damaged header instance #2037 retrieved, skipping.
error: rpmdb: damaged header instance #2051 retrieved, skipping.
error: rpmdb: damaged header instance #2034 retrieved, skipping.
error: rpmdb: damaged header instance #2031 retrieved, skipping.
error: rpmdb: damaged header instance #2047 retrieved, skipping.
error: rpmdb: damaged header instance #2028 retrieved, skipping.
error: rpmdb: damaged header instance #2044 retrieved, skipping.
error: rpmdb: damaged header instance #2029 retrieved, skipping.
error: rpmdb: damaged header instance #2045 retrieved, skipping.
error: rpmdb: damaged header instance #2042 retrieved, skipping.
error: rpmdb: damaged header instance #2039 retrieved, skipping.
error: rpmdb: damaged header instance #2049 retrieved, skipping.
error: rpmdb: damaged header instance #2036 retrieved, skipping.
error: rpmdb: damaged header instance #2052 retrieved, skipping.
error: rpmdb: damaged header instance #2033 retrieved, skipping.
error: rpmdb: damaged header instance #2041 retrieved, skipping.
error: rpmdb: damaged header instance #2030 retrieved, skipping.
error: rpmdb: damaged header instance #2038 retrieved, skipping.
error: rpmdb: damaged header instance #2046 retrieved, skipping.
error: rpmdb: damaged header instance #2050 retrieved, skipping.
error: rpmdb: damaged header instance #2035 retrieved, skipping.
error: rpmdb: damaged header instance #2043 retrieved, skipping.
error: rpmdb: damaged header instance #2053 retrieved, skipping.
error: rpmdb: damaged header instance #2032 retrieved, skipping.
error: rpmdb: damaged header instance #2040 retrieved, skipping.
error: rpmdb: damaged header instance #2048 retrieved, skipping.
error: rpmdb: damaged header instance #2037 retrieved, skipping.
error: rpmdb: damaged header instance #2051 retrieved, skipping.
error: rpmdb: damaged header instance #2034 retrieved, skipping.
error: rpmdb: damaged header instance #2031 retrieved, skipping.
error: rpmdb: damaged header instance #2047 retrieved, skipping.
error: rpmdb: damaged header instance #2028 retrieved, skipping.
error: rpmdb: damaged header instance #2044 retrieved, skipping.
error: rpmdb: damaged header instance #2029 retrieved, skipping.
error: rpmdb: damaged header instance #2045 retrieved, skipping.
error: rpmdb: damaged header instance #2042 retrieved, skipping.
error: rpmdb: damaged header instance #2039 retrieved, skipping.
error: rpmdb: damaged header instance #2049 retrieved, skipping.
error: rpmdb: damaged header instance #2036 retrieved, skipping.
error: rpmdb: damaged header instance #2052 retrieved, skipping.
error: rpmdb: damaged header instance #2033 retrieved, skipping.
error: rpmdb: damaged header instance #2041 retrieved, skipping.
error: rpmdb: damaged header instance #2030 retrieved, skipping.
error: rpmdb: damaged header instance #2038 retrieved, skipping.
error: rpmdb: damaged header instance #2046 retrieved, skipping.
error: rpmdb: damaged header instance #2050 retrieved, skipping.
error: rpmdb: damaged header instance #2035 retrieved, skipping.
error: rpmdb: damaged header instance #2043 retrieved, skipping.
error: rpmdb: damaged header instance #2053 retrieved, skipping.
error: rpmdb: damaged header instance #2032 retrieved, skipping.
error: rpmdb: damaged header instance #2040 retrieved, skipping.
error: rpmdb: damaged header instance #2048 retrieved, skipping.
error: rpmdb: damaged header instance #2037 retrieved, skipping.
error: rpmdb: damaged header instance #2051 retrieved, skipping.
error: rpmdb: damaged header instance #2034 retrieved, skipping.
error: rpmdb: damaged header instance #2031 retrieved, skipping.
error: rpmdb: damaged header instance #2047 retrieved, skipping.
error: rpmdb: damaged header instance #2028 retrieved, skipping.
error: rpmdb: damaged header instance #2044 retrieved, skipping.
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
W: В Вашей системе установлено несколько версий пакета "libobasis6.1-core".

Этот пакет не может быть обновлён обычным путём до тех пор, пока Вы не
оставите только одну его версию. Чтобы оставить установленными несколько версий,
и
W: Возможно, Вам потребуется запустить `apt-get update' для исправления.

# rpm --rebuildb -vv
...
D: добавляется "7bc533d411bcc606a3f4c3ef6d24481a398b1ba3" в индекс Sha1header.
D:   +++       1266 vlc-plugin-ogg-2.2.6.20170917-alt1.M80P.1
D: добавляется "vlc-plugin-ogg" в индекс Name.
D: добавляется 4 записей в индекс Basenames
D: добавляется "Видео" в индекс Group.
D: добавляется 7 записей в индекс Requirename
D: добавляется "vlc-plugin-ogg" в индекс Providename.
D: добавляется 3 записей в индекс Dirnames
D: добавляется 1 записей в индекс Installtid
D: добавляется 1 записей в индекс Sigmd5
D: добавляется "268a4f09c911aa5294705bf9ba96d4491c4ba52b" в индекс Sha1header.
*** Error in `/usr/lib/rpm/rpmd': double free or corruption (!prev): 0x00000000025054a0 ***
======= Backtrace: =========
/lib64/libc.so.6(+0x6f325)[0x7fab7262f325]
/lib64/libc.so.6(+0x74ae6)[0x7fab72634ae6]
/lib64/libc.so.6(+0x752ce)[0x7fab726352ce]
/usr/lib64/librpmdb-4.0.4.so(+0xca47)[0x7fab72b7ca47]
/usr/lib64/librpmdb-4.0.4.so(+0xcdee)[0x7fab72b7cdee]
/usr/lib64/librpmdb-4.0.4.so(+0x12a73)[0x7fab72b82a73]
/usr/lib64/librpmdb-4.0.4.so(rpmdbAdd+0x329)[0x7fab72b86059]
/usr/lib64/librpmdb-4.0.4.so(rpmdbRebuild+0x4ea)[0x7fab72b8725a]
/usr/lib/rpm/rpmd[0x401d6c]
/lib64/libc.so.6(__libc_start_main+0xf0)[0x7fab725e07f0]
/usr/lib/rpm/rpmd[0x401f59]
======= Memory map: ========
00400000-00403000 r-xp 00000000 08:02 525025                             /usr/lib/rpm/rpmd
00602000-00603000 r--p 00002000 08:02 525025                             /usr/lib/rpm/rpmdАварийный останов

Как исправить ?
« Последнее редактирование: 10.07.2019 13:18:22 от berkut_174 »
Сноси Винду, переходи на Линукс ! :)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 6 971
    • Email
# rpmquery -a libobasis6.1-core
ошибка: rpmdb: получен поврежденный заголовок #2029, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2045, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2042, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2039, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2049, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2036, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2052, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2033, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2041, пропускается.
libobasis6.1-core-6.1.6.3-3
ошибка: rpmdb: получен поврежденный заголовок #2030, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2038, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2046, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2050, пропускается.
libobasis6.1-core-6.1.6.3-3
ошибка: rpmdb: получен поврежденный заголовок #2035, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2043, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2053, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2032, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2040, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2048, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2037, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2051, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2034, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2031, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2047, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2028, пропускается.
ошибка: rpmdb: получен поврежденный заголовок #2044, пропускается.

# rpmi -e libobasis6.1-core-6.1.6.3-3
ошибка: пакет libobasis6.1-core-6.1.6.3-3 не установлен
rpmdb: Page 12518: first page in overflow chain has a prev_pgno 12517
rpmdb: Page 12707: overflow item incomplete
rpmdb: Page 12552: first page in overflow chain has a prev_pgno 12551
rpmdb: Page 12552: overflow page linked twice from leaf or data page
rpmdb: Page 12543: first page in overflow chain has a prev_pgno 12542
rpmdb: Page 12543: overflow page linked twice from leaf or data page
rpmdb: Page 12532: first page in overflow chain has a prev_pgno 12531
rpmdb: Page 12532: overflow page linked twice from leaf or data page
rpmdb: Page 12565: first page in overflow chain has a prev_pgno 12564
rpmdb: Page 12565: overflow page linked twice from leaf or data page
rpmdb: Page 12529: first page in overflow chain has a prev_pgno 12528
rpmdb: Page 12529: overflow page linked twice from leaf or data page
rpmdb: Page 12600: first page in overflow chain has a prev_pgno 12599
rpmdb: Page 12600: overflow page linked twice from leaf or data page
rpmdb: Page 12526: first page in overflow chain has a prev_pgno 12525
rpmdb: Page 12526: overflow page linked twice from leaf or data page
rpmdb: Page 12540: first page in overflow chain has a prev_pgno 12539
rpmdb: Page 12540: overflow page linked twice from leaf or data page
rpmdb: Page 12518: overflow page linked twice from leaf or data page
rpmdb: Page 12520: first page in overflow chain has a prev_pgno 12519
rpmdb: Page 12520: overflow page linked twice from leaf or data page
rpmdb: Page 12531: first page in overflow chain has a prev_pgno 12530
rpmdb: Page 12531: overflow page linked twice from leaf or data page
rpmdb: Page 12554: first page in overflow chain has a prev_pgno 12553
rpmdb: Page 12554: overflow page linked twice from leaf or data page
rpmdb: Page 12567: first page in overflow chain has a prev_pgno 12566
rpmdb: Page 12567: overflow page linked twice from leaf or data page
rpmdb: Page 12511: overflow page linked twice from leaf or data page
rpmdb: Page 12528: first page in overflow chain has a prev_pgno 12527
rpmdb: Page 12528: overflow page linked twice from leaf or data page
rpmdb: Page 12546: first page in overflow chain has a prev_pgno 12545
rpmdb: Page 12546: overflow page linked twice from leaf or data page
rpmdb: Page 12602: first page in overflow chain has a prev_pgno 12601
rpmdb: Page 12602: overflow page linked twice from leaf or data page
rpmdb: Page 12523: first page in overflow chain has a prev_pgno 12522
rpmdb: Page 12523: overflow page linked twice from leaf or data page
rpmdb: Page 12533: first page in overflow chain has a prev_pgno 12532
rpmdb: Page 12533: overflow page linked twice from leaf or data page
rpmdb: Page 12560: first page in overflow chain has a prev_pgno 12559
rpmdb: Page 12560: overflow page linked twice from leaf or data page
rpmdb: Page 12530: first page in overflow chain has a prev_pgno 12529
rpmdb: Page 12530: overflow page linked twice from leaf or data page
rpmdb: Page 12580: first page in overflow chain has a prev_pgno 12579
rpmdb: Page 12580: overflow page linked twice from leaf or data page
rpmdb: Page 12527: first page in overflow chain has a prev_pgno 12526
rpmdb: Page 12527: overflow page linked twice from leaf or data page
rpmdb: Page 12521: first page in overflow chain has a prev_pgno 12520
rpmdb: Page 12521: overflow page linked twice from leaf or data page
rpmdb: Page 12558: first page in overflow chain has a prev_pgno 12557
rpmdb: Page 12558: overflow page linked twice from leaf or data page
rpmdb: Page 12515: first page in overflow chain has a prev_pgno 12514
rpmdb: Page 12515: overflow page linked twice from leaf or data page
rpmdb: Page 12549: first page in overflow chain has a prev_pgno 12548
rpmdb: Page 12549: overflow page linked twice from leaf or data page
rpmdb: /var/lib/rpm/Packages: DB_VERIFY_BAD: Database verification failed
ошибка: ошибка(4) db-30972 из db->verify: DB_VERIFY_BAD: Database verification failed
Сноси Винду, переходи на Линукс ! :)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 6 971
    • Email
Это вообще реально починить ?

Произошло всё в момент когда работал apt-get и в этом время puppet ставил LO 6.1 через 'rpm -Uvh *.rpm', где-то в этом месте база повредилась.
Сноси Винду, переходи на Линукс ! :)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 6 971
    • Email
Эти рекомендации выполнить не могу https://rpm.org/user_doc/db_recovery.html, не знаю где взять rpmdb_dump, rpmdb_load и rpmdb_verify.
Сноси Винду, переходи на Линукс ! :)

Оффлайн rabochyITs

  • Давно тут
  • **
  • Сообщений: 615
  • Евгений
libobasis6.1-core
# info apt-get
apt-get -f install
или apt-get -m install
apt-get remove правильное_название_пакета

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 6 971
    • Email
apt-get -f install
или apt-get -m install
apt-get remove правильное_название_пакета
Сейчас ушёл уже от компа, но apt-get remove и apt-get -f install пробовал одни из первых, они тоже падают с ошибкой, завтра скину вывод. Ключ -m ни разу не использовал, проверю.
Сноси Винду, переходи на Линукс ! :)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 6 971
    • Email
# rpmi -e libobasis6.1-core-6.1.6.3-3
ошибка: пакет libobasis6.1-core-6.1.6.3-3 не установлен
Ну вот у меня на другой машине примерно также ругался, только там дело было в пакете hplip-ps-PPDs и по-другому поводу. Были установлены версии 3.19.3 и 3.19.5 одновременно. Я подключил архив от 10.04.2019, сделал apt-get update, потом вроде установил или удалил hplip-ps-PPDs (возможно apt-get -f install выполнил), далее вернулся на p8 и тогда rpmi -e сработал. А тут как быть...
« Последнее редактирование: 10.07.2019 15:38:40 от berkut_174 »
Сноси Винду, переходи на Линукс ! :)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 6 971
    • Email
rpmdb_dump, rpmdb_load и rpmdb_verify
Так что, никто не знает насчёт этих утилит ? Так красиво написано и похоже может мне помочь...
Сноси Винду, переходи на Линукс ! :)

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 675
  • Кто ищет, тот найдёт.
    • Email
Произошло всё в момент когда работал apt-get и в этом время puppet ставил LO 6.1 через 'rpm -Uvh *.rpm', где-то в этом месте база повредилась.
А вот так делать не следует. Линукс хоть и многозадачен, но с базой пакетов лучше быть осторожнее и не выполнять в параллель несколько задач, модифицирующих базу.

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 6 971
    • Email
А вот так делать не следует. Линукс хоть и многозадачен, но с базой пакетов лучше быть осторожнее и не выполнять в параллель несколько задач, модифицирующих базу.
Это понятно, но вопрос сейчас не в этом, нужно восстановить базу.
Понятно, что вина моя, я вроде сделал перед ручной установкой пакетов systemctl stop puppet, но agent продолжил работать. Теперь вот разгребаю.
Сноси Винду, переходи на Линукс ! :)

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 675
  • Кто ищет, тот найдёт.
    • Email
сделал перед ручной установкой пакетов systemctl stop puppet, но agent продолжил работать
Некоторые современные сервисы уже просто так не прибить. Они иной раз выступают в двух ипостасях: сам сервис и т.н. автозапускалка, которая слушает порт либо определенные события на шине обмена сообщениями и в случае поступления некоторых сообщений или запросов стартует сам сервис для их обработки. Но, возможно, что в вашем случае сервис просто не остановился по какой-то причине.

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 6 971
    • Email
Но, возможно, что в вашем случае сервис просто не остановился по какой-то причине.
Нет, агент продолжает висеть в процессах, первый раз после запуска компьютера он отрабатывает точно, пока не прибьёшь его.

Решил проблему следующим образом, но только потому что у меня несколько однотипных машин. На другой машине привёл dist-upgrade к тому, который был до повреждения базы на проблемной машине. Перенёс оттуда файл /var/lib/rpm/Packages на проблемную машину, выполнил удаление __db файлов в /var/lib/rpm/, удалил /var/log/rpmpkgs, сделал rpm --rebuilddb, apt-get update, apt-get dist-upgrade, update-kernel, remove-old-kernels,..
Теперь всё норм.

Как быть тем, у кого нет однотипной машины, не подскажу. Решения разнообразные в сети находил, но они для ALT видимо не подходят, не разобрался я в общем.

[решено]
Сноси Винду, переходи на Линукс ! :)