Автор Тема: P9 nvidia GT 430 не устанавливается драйвер  (Прочитано 4641 раз)

Оффлайн kir_84

  • Завсегдатай
  • *
  • Сообщений: 19
Здравствуйте!
Установлена Рабочая станция 9 платформа. Пытаюсь установить драйвера для видеокарточки nvidia GT 430 по инструкции, однако, согласно lspci всё равно используется nouveau:
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 430] (rev a1) (prog-if 00 [VGA controller])
Flags: bus master, fast devsel, latency 0, IRQ 27
Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
Memory at f0000000 (64-bit, prefetchable) [size=128M]
Memory at f8000000 (64-bit, prefetchable) [size=32M]
I/O ports at dc00 [size=128]
Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: nouveau
Команда nvidia-settings выдает такое:
(nvidia-settings:2856): dbind-WARNING **: 21:06:18.745: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-ul0OHkhxHw: В соединении отказано

ERROR: Unable to load info from any available system.
При этом, в альтинаторе указаны проприетарные драйвера (скриншот прилагается) ???
Подскажите, пожалуйста, что делать?

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 494
  • Sunny 273 RUS crew
У этой инструкции есть ссылки, там есть ссылка на предыдущую редакцию. В ней упоминается использование /etc/modprobe.d/blacklist-video.conf. Может быть поможет. Ну или просто удалить nouveau, хотя может быть чревато в случае, если nvidia не заработает, хотя последнее вряд ли. Тут кто первым встал, того и тапки: ядерный модуль может быть загружен чем-нибудь до xorg.

Оффлайн kir_84

  • Завсегдатай
  • *
  • Сообщений: 19
Попробовал по этой инструкции, прописал /etc/modprobe.d/blacklist-video.conf, /etc/X11/xorg.conf.d/50-driver.conf.
В результате графика вообще не стартует, после команды xsetup-monitor -d nouveau графика грузится, однако драйвер не nvidia. :(
Удалять nouveau, наверное, не стоит.

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 494
  • Sunny 273 RUS crew
однако драйвер не nvidia. :(
И не nouveau? А какая версия драйвера вообще нужна для GT 430? И что в /var/log/Xorg.0.log про nvidia пишут?

И попробуйте драйвер обновить: неделю в очереди на обновление в p9 задание 240331 висит с 440.31. Можно или дожтаться, или не ждать: https://www.altlinux.org/Карманы.
« Последнее редактирование: 08.11.2019 23:07:48 от asy »

Оффлайн kir_84

  • Завсегдатай
  • *
  • Сообщений: 19
Nouveau, конечно. Нужна была 390 версия.

Удалил /etc/X11/xorg.conf, перезагрузился, зашёл в альтератор, а там nvidia(kms). Поменял на проприетарный драйвер, перезагрузился, всё работает.:-o Драйвер от nvidia.
Скорее всего напортачил, когда воевал с dpms.

Спасибо!