Автор Тема: Система стартует только в половине случаев запуска.  (Прочитано 15369 раз)

Оффлайн Evg82

  • Завсегдатай
  • *
  • Сообщений: 7
    • Email
Поставил дистрибутив alt-workstation-9.0-x86_64.
Система загружается, где то в половине случаев загрузки.
При запуске может зависнуть и монитор уходит в сон.
Иногда запускается и работает без сбоев.

Железо:
Проц: athlon x460
Мб: gigabyte ga 780t-d3l
ОЗУ: 8гб
Видео: MSI radeon r230
Винт: SSD

На томже железе Win10 загружается и работает нормально.
Пробовал также устанавливать manjaro, Ubuntu, mint. Так вот там такая же проблема. Загружается через раз. И если загрузилась, то работает стабильно.

Что делать что бы узнать в чем причина зависаний, и если возможно устранить?

Оффлайн Александр Ерещенко

  • Давно тут
  • **
  • Сообщений: 361
При первой нормальной загрузке (после ненормальной) посмотрите в логи предыдущей загрузки:
journalctl --boot=-1
Листайте, смотрите, может что подозрительное (особенно последние записи) и будет
Можно сравнить с последней загрузкой:
journalctl -b
# или то же самое, но команда развернуто
journalctl --boot=0
« Последнее редактирование: 31.05.2020 10:04:36 от Александр Ерещенко »

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 3 773
  • antohami@
На томже железе Win10 загружается и работает нормально.

Отключите быструю загрузку у Windows 10.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 14
Ещё причиной подобного может быть плохой контакт БП и материнки. Но у Вас "Винда" нормально загружается...

Оффлайн Evg82

  • Завсегдатай
  • *
  • Сообщений: 7
    • Email
На томже железе Win10 загружается и работает нормально.

Отключите быструю загрузку у Windows 10.
Отключил. Винда загружается нормально.
По линуксу вопросы. Почему все дистрибутивы ведут себя одинаково, т. е. зависают иногда при загрузке? Может быть из-за драйвера какого-либо который один и тот же во всех дистрибутивах?

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 440
Скорее всего из-за видеокарты. У вас какой драйвер в xorg используется?

Оффлайн Александр Ерещенко

  • Давно тут
  • **
  • Сообщений: 361
Почему все дистрибутивы ведут себя одинаково, т. е. зависают иногда при загрузке? Может быть из-за драйвера какого-либо который один и тот же во всех дистрибутивах?
Так Вы в логи смотрели? На каком этапе зависает?
И зависает ли? По Ctrl-Alt-F2 переключается на консоль? Если да, то залогиниться и смотреть логи. Кроме journalctl, посмотреть ещё и /var/log/Xorg.0.log - для текущей загрузки, или /var/log/Xorg.1.log - для предыдущей (для ориентировки смотрите на время создания этих файлов)

Оффлайн Evg82

  • Завсегдатай
  • *
  • Сообщений: 7
    • Email
Почему все дистрибутивы ведут себя одинаково, т. е. зависают иногда при загрузке? Может быть из-за драйвера какого-либо который один и тот же во всех дистрибутивах?
Так Вы в логи смотрели? На каком этапе зависает?
И зависает ли? По Ctrl-Alt-F2 переключается на консоль? Если да, то залогиниться и смотреть логи. Кроме journalctl, посмотреть ещё и /var/log/Xorg.0.log - для текущей загрузки, или /var/log/Xorg.1.log - для предыдущей (для ориентировки смотрите на время создания этих файлов)
Нет на консоль не переключается. Сейчас запускаюсь с флешки, поэтому предыдущих логов нет.
До этого на manjaro смотрел логи там Xorg завершает свою работу и отключает клавиатуру и мышку. И монитор уходит в спячку.

И еще. Недавно был подозрительный случай на Винде. Оставил комп, он ушел в спячку. А обратно не вышел, хотя винт мигал иногда и доп. ндикатор который работает через ком порт данные обновлял. И из спячки комп не вышел.
Это получается какой-то сбой в железе появился? Или видюха или мб, так?

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 14
Скорее всего в железе дело. Возможно плохо контачит блок питания и материнская плата.
А "вертушки" не останавливались?

Оффлайн Evg82

  • Завсегдатай
  • *
  • Сообщений: 7
    • Email
Скорее всего в железе дело. Возможно плохо контачит блок питания и материнская плата.
А "вертушки" не останавливались?
Вертушки это вентиляторы? Если они, то нет.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 14
Вертушки это вентиляторы? Если они, то нет.
Да, я о вентиляторах. Просто несколько недель назад у самого так было. компьютер то зависал, то останавливались вентиляторы. Думал, что блок питания "помирает" потихоньку, оказалось просто там где к материнке подсоединяется блок питания был плохой контакт. Немного поправил штеккер в разъёме, вроде теперь всё нормально.

Оффлайн Evg82

  • Завсегдатай
  • *
  • Сообщений: 7
    • Email
Вертушки это вентиляторы? Если они, то нет.
Да, я о вентиляторах. Просто несколько недель назад у самого так было. компьютер то зависал, то останавливались вентиляторы. Думал, что блок питания "помирает" потихоньку, оказалось просто там где к материнке подсоединяется блок питания был плохой контакт. Немного поправил штеккер в разъёме, вроде теперь всё нормально.
Поправил штекер на мп - не помогло.
Просто если бы были зависания везде в процессе работы, а то только при загрузке и приблизительно в одном и том же месте.
Интересно узнать в чем проблема. Я думаю что в дровах, если там параллельный запуск, то получаются какие то не благоприятные условия иногда, поэтому зависает. Только как это найти и зафиксировать. Вот вопрос?

Онлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 8 827
  • UNIX System V init
Только как это найти и зафиксировать. Вот вопрос?

Говорили же, в логах.
И сраный сыстемдэ имеет дурную привычку менять порядок запуска сервисов. И если такое происходит, на сыстэмдэ надо изобретать лисапет, - порядок старта сервисов как на sysv.
ZX Spectrum 128K
Привет от NM:  # echo -e "\n[device]\nwifi.scan-rand-mac-address=no" >> /etc/NetworkManager/NetworkManager.conf

Оффлайн Evg82

  • Завсегдатай
  • *
  • Сообщений: 7
    • Email
Только как это найти и зафиксировать. Вот вопрос?

Говорили же, в логах.
И сраный сыстемдэ имеет дурную привычку менять порядок запуска сервисов. И если такое происходит, на сыстэмдэ надо изобретать лисапет, - порядок старта сервисов как на sysv.
Поставил Линукс void. Там такая же проблема с загрузкой. Там не систем мд.
Видимо какой то баг в железе. Хотя винда как-то обходит его. И грузится нормально.

Оффлайн Александр Ерещенко

  • Давно тут
  • **
  • Сообщений: 361
Так посмотрите же в логи. К чему эти гадания?