Автор Тема: при создании VM с параметром ОС Windows 10/2016/2019 , виртуальная машина не запускается  (Прочитано 2068 раз)

Оффлайн BiZoN_45

  • Завсегдатай
  • *
  • Сообщений: 6
при создании VM с параметром ОС Windows 10/2016/2019 , виртуальная машина не запускается ошибка Hyper-V paravirtualized IPI (hv-ipi) is not supported by kernel
qemu-system-x86_64: kvm_init_vcpu failed: Function not implemented
TASK ERROR: start failed: command '/usr/bin/qemu-system-x86_64 -id 101 -name server-1C -chardev 'socket,id=qmp,path=/run/qemu-server/101.qmp,server,nowait' -mon 'chardev=qmp,mode=control' -chardev 'socket,id=qmp-event,path=/run/qmeventd.sock,reconnect=5' -mon 'chardev=qmp-event,mode=control' -pidfile /run/qemu-server/101.pid -daemonize -smbios 'type=1,uuid=04a65361-c643-47a2-9a79-dfa24b506d63' -smp '4,sockets=1,cores=4,maxcpus=4' -nodefaults -boot 'menu=on,strict=on,reboot-timeout=1000,splash=/usr/share/qemu-server/bootsplash-std.jpg' -vnc unix:/run/qemu-server/101.vnc,password -no-hpet -cpu 'kvm64,+lahf_lm,+sep,+kvm_pv_unhalt,+kvm_pv_eoi,hv_spinlocks=0x1fff,hv_vapic,hv_time,hv_reset,hv_vpindex,hv_runtime,hv_relaxed,hv_synic,hv_stimer,hv_ipi,enforce' -m 10240 -device 'vmgenid,guid=8c2a05cd-f2b7-427b-bf7b-63a1251addcd' -readconfig /usr/share/qemu-server/pve-q35-4.0.cfg -device 'usb-tablet,id=tablet,bus=ehci.0,port=1' -device 'virtio-rng-pci,id=rng,bus=pci.0,addr=0x12' -device 'VGA,id=vga,vgamem_mb=512,bus=pcie.0,addr=0x1' -device 'virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3' -iscsi 'initiator-name=iqn.2020-06.ua.alt:01:d484a5591df' -device 'lsi,id=scsihw0,bus=pci.0,addr=0x5' -drive 'file=/var/lib/libvirt/images/images/101/vm-101-disk-0.vmdk,if=none,id=drive-scsi0,discard=on,format=vmdk,cache=none,aio=native,detect-zeroes=unmap' -device 'scsi-hd,bus=scsihw0.0,scsi-id=0,drive=drive-scsi0,id=scsi0,bootindex=200' -drive 'file=/var/lib/vz/template/iso/ru_windows_10_1909_updated_feb_2020_x64_dvd.iso,if=none,id=drive-scsi1,media=cdrom,aio=threads' -device 'scsi-cd,bus=scsihw0.0,scsi-id=1,drive=drive-scsi1,id=scsi1,bootindex=100' -rtc 'driftfix=slew,base=localtime' -machine 'accel=kvm,type=q35' -global 'kvm-pit.lost_tick_policy=discard'' failed: exit code 1
не могу понять в чем причина , в интернете не нашел решения проблемы .

Онлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 440

Оффлайн BiZoN_45

  • Завсегдатай
  • *
  • Сообщений: 6
Linux PVE01.corp.dcrb.ru 4.19.87-std-def-alt1 #1 SMP Wed Dec 11 15:44:37 UTC 2019 x86_64 GNU/Linux

Онлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 440
а если убрать из команды запуска все hv_***?

Возможно что в альте пока поддерживается только KVM - https://www.altlinux.org/PVE

Как вариант можно попробовать обновить ядро
apt-get update
update-kernel
reboot

Оффлайн BiZoN_45

  • Завсегдатай
  • *
  • Сообщений: 6
Выбрал тип ОС другие, интерфейс жесткого диска и CD - SATA, Windows server 2016 установился штатно без ошибок.