Автор Тема: Отсутсвуют доступные обновления std-def (ALT 8 SP Server)  (Прочитано 4301 раз)

Оффлайн Сhocobo

  • Завсегдатай
  • *
  • Сообщений: 6
Добрый день.

Возникла потребность по обновлению ядра на ALT 8 SP
]# cat /etc/redhat-release
ALT 8 SP Server
# uname -r
4.4.86-std-def-alt0.M80C.1

update-kernel упорно заявляет, что текущая версия актуальна и менять ее ни на что не хочет, в том числе с ключом force

]# update-kernel
Running kernel version: kernel-image-std-def-1:4.4.86-alt0.M80C.1
Checking for available kernel packages...
Latest kernel std-def-1:4.4.86-alt0.M80C.1@1505318951 is already installed on your system.
No upgrade is needed. Use -f for force.

Источники апта прописаны следующие:
Спойлер
# ALT Certified 8
rpm [cert8] http://ftp.altlinux.org/pub/distributions/ALTLinux c8/branch/x86_64 classic
rpm [cert8] http://ftp.altlinux.org/pub/distributions/ALTLinux c8/branch/x86_64-i586 classic
rpm [cert8] http://ftp.altlinux.org/pub/distributions/ALTLinux c8/branch/noarch classic

Прошу подсказать что можно предпринять чтоб обновить std-def?
Cпасибо

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 440
apt-get updateсначала

Оффлайн Сhocobo

  • Завсегдатай
  • *
  • Сообщений: 6
ну это само собой разумеется :-)
под обновление, кроме ядра планировались и другие пакеты, те что с apt ставятся штатно вопросов не вызвали. тот жесвеженький curl

# apt-cache policy curl
curl:
  Installed: 7.66.0-alt1:c8.1+237385.100.1.1@1568183822
  Candidate: 7.66.0-alt1:c8.1+237385.100.1.1@1568183822
  Version Table:
 *** 7.66.0-alt1:c8.1+237385.100.1.1@1568183822 0
        500 http://ftp.altlinux.org c8/branch/x86_64/classic pkglist
        100 RPM Database

А вот обвязка для ядра почему-то сопротивляется:-(
В теле скрипта есть
# get list of all available kernel packages
KERNEL_PKGS:

Спойлер
# apt-cache pkgnames kernel-image
kernel-image-domU-std-debug
kernel-image-std-restricted#1:4.9.190-alt0.M80C.1:c8.1+236583.100.1.1@1566754585
kernel-image-std-4.9#1:4.9.227-alt0.M80C.1:c8.1+253189.100.1.1@1591885794
kernel-image-domU-std-restricted#1:4.9.190-alt0.M80C.1:c8.1+236583.100.1.1@1566754585
kernel-image-std-def
kernel-image-un-def
kernel-image-domU-std-restricted
kernel-image-std-4.9
kernel-image-domU-std-4.9#1:4.9.227-alt0.M80C.1:c8.1+253189.100.1.1@1591885794
kernel-image-un-def#1:4.19.128-alt0.M80C.1:c8.1+253183.100.1.1@1591879312
kernel-image-std-restricted
kernel-image-std-debug
kernel-image-std-debug#1:4.9.135-alt0.M80C.2:c8.1+225346.30070.48.1@1555523764
kernel-image-srv-restricted#1:4.9.190-alt0.M80C.1:c8.1+236582.100.1.1@1566751087
kernel-image-domU-std-4.9
kernel-image-domU-un-def
kernel-image-std-def#1:4.4.86-alt0.M80C.1@1505318951
kernel-image-domU-srv-restricted#1:4.9.190-alt0.M80C.1:c8.1+236582.100.1.1@1566751087
kernel-image-domU-un-def#1:4.19.128-alt0.M80C.1:c8.1+253183.100.1.1@1591879312
kernel-image-domU-std-debug#1:4.9.135-alt0.M80C.2:c8.1+225346.30070.48.1@1555523764
kernel-image-domU-srv-restricted
kernel-image-srv-restricted

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 104
  • Sunny 273 RUS crew
Что-то не так: https://packages.altlinux.org/en/c8/srpms/kernel-image-std-def
Должно быть 4.4.211 сейчас.

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 440
ну это само собой разумеется :-)
может у вас кто-то пакеты с ядром на hold поставил?

Оффлайн Сhocobo

  • Завсегдатай
  • *
  • Сообщений: 6
кто-то пакеты с ядром на hold поставил?


# ls -l /etc/apt/apt.conf.d/
total 0
# cat /etc/apt/apt.conf
/*
 * This is the main configuration file for the APT suite of tools,
 * see apt.conf(5) for details.
 */

// See apt-cdrom(8) for details.
Acquire::CDROM::Copy "true";
Acquire::CDROM::mount "/media/ALTLinux";

Acquire::https::proxy "http://someproxy:3128/";
Acquire::http::proxy "http://someproxy:3128/";
Acquire::ftp::proxy "http://someproxy:3128/";

RPM
{
        Allow-Duplicated {
                // Old-style kernels.
                "^(NVIDIA_)?(kernel|alsa)[0-9]*(-adv|-linus)?($|-up|-smp|-secure|-custom|-enterprise|-BOOT|-tape|-aureal)";
                // New-style kernels.
                "^kernel-(image|modules)-.*";
        };
        Hold {
                // Old-style kernels.
                "^(kernel|alsa)[0-9]+-source";
        };
};

На что-то кастомное данный холд вроде не похож, что скажете?
из ручного только указание использовать нужный мне сквид.

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 104
  • Sunny 273 RUS crew
На что-то кастомное данный холд вроде не похож, что скажете?
Полтергейст и должно работать. Больше ничего а голову не приходит. ftp.altlinux.org не может резолвиться в IP какого-нибудь локального необновляемого прокси? А Сквид точно у себя кэш обновил?

Оффлайн Сhocobo

  • Завсегдатай
  • *
  • Сообщений: 6
Не, прокси не кэширующий, его задача просто быть отверстием в мир)

Ну и чтоб исключить его влияние, т.к. на нем такой же альт и такое же поведение вот аналогичный прямой сценарий без проксей (с самого прокси-сервера)

# apt-get update
Get:1 ftp://ftp.altlinux.org c8/branch/x86_64 release [884B]
Get:2 ftp://ftp.altlinux.org c8/branch/x86_64-i586 release [543B]
Get:3 ftp://ftp.altlinux.org c8/branch/noarch release [679B]
Fetched 2106B in 0s (23.2kB/s)
Hit ftp://ftp.altlinux.org c8/branch/x86_64/classic pkglist
Hit ftp://ftp.altlinux.org c8/branch/x86_64/classic release
Hit ftp://ftp.altlinux.org c8/branch/x86_64-i586/classic pkglist
Hit ftp://ftp.altlinux.org c8/branch/x86_64-i586/classic release
Hit ftp://ftp.altlinux.org c8/branch/noarch/classic pkglist
Hit ftp://ftp.altlinux.org c8/branch/noarch/classic release
Reading Package Lists... Done
Building Dependency Tree... Done
# nslookup ftp.altlinux.org
Server:         127.0.0.1
Address:        127.0.0.1#53

Non-authoritative answer:
Name:   ftp.altlinux.org
Address: 62.152.55.238

# update-kernel
Running kernel version: kernel-image-std-def-1:4.4.86-alt0.M80C.1
Checking for available kernel packages...
Latest kernel std-def-1:4.4.86-alt0.M80C.1 is already running on your system.
No upgrade is needed. Use -f for force.

# apt-get -u upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be upgraded
  certmonger libgnutls30
The following packages have been kept back
  efibootmgr glibc-core glibc-gconv-modules glibc-locales glibc-nss glibc-pthread glibc-timezones glibc-utils guile18 i586-glibc-core.32bit iconv libipa_hbac libldb
  libnetapi libnss-myhostname libpam0 libpasswdqc libpolkit libpython libsmbclient libsss_certmap libsss_idmap libsss_nss_idmap libtalloc libtevent libwbclient nscd
  ntp-utils ntpdate ntpq openssh-clients openssh-common openssh-server pam pam0_passwdqc pam_systemd passwdqc-utils perl-base perl-devel perl-threads polkit ppp
  python python-base python-dev python-module-cryptography python-module-ipa_hbac python-modules python-modules-bsddb python-modules-compiler python-modules-ctypes
  python-modules-curses python-modules-email python-modules-encodings python-modules-hotshot python-modules-json python-modules-logging python-modules-multiprocessing
  python-modules-sqlite3 python-modules-unittest python-modules-xml python-tools-2to3 python3 python3-base samba-client samba-client-libs samba-common-libs
  samba-common-tools samba-libs sssd sssd-ad sssd-client sssd-ipa sssd-krb5 sssd-krb5-common sssd-pac strace systemd systemd-services systemd-utils udev udev-extras
2 upgraded, 0 newly installed, 0 removed and 82 not upgraded.
Need to get 1318kB of archives.
After unpacking 533kB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.

Магия, не иначе) Но что делать с проблемой пока неясно.

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 104
  • Sunny 273 RUS crew
Магия, не иначе) Но что делать с проблемой пока неясно.
Ну ещё правда может что-то с индексами в c8.

UPD: правда что-то странное. У меня есть система с p7, ядро из c8 должно бы поставиться, но
# update-kernel -t std-def
update-kernel: There are no available kernels with kernel flavour std-def
« Последнее редактирование: 23.06.2020 18:07:46 от asy »

Оффлайн Сhocobo

  • Завсегдатай
  • *
  • Сообщений: 6
no available kernels with kernel flavour std-def
И оно бы вероятно должно здесь также отсвечивать среди пакетов?
Спойлер

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 104
  • Sunny 273 RUS crew
Действительно. Значит удалили.

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 440
тогда только
update-kernel -t std-4.9остается

Оффлайн Сhocobo

  • Завсегдатай
  • *
  • Сообщений: 6
Что ж, прискорбно, если 4.4.211 ожидать не приходится ???
Странно, что не находится отсылок к этим новшествам, где бы почитать и ознакомиться.
Спасибо за информацию.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 17 782
    • Домашняя страница
    • Email
Почитать в техподдержке и в образах после инспекционного контроля.
Андрей Черепанов (cas@)

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 104
  • Sunny 273 RUS crew
Почитать в техподдержке и в образах после инспекционного контроля.
Вообще 4.4 действитеьно удалили зря, тем более раз флавор сменили для 4.9. Мне некоторое время приходилось его (4.4) из c8 тягать по разным причинам.

И это, а почему оно до сих пор ищется на p.a.o? Там значит индексы не обновляются нормально?