Автор Тема: Ошибка при обновлении репозитория  (Прочитано 1907 раз)

Оффлайн him

  • Завсегдатай
  • *
  • Сообщений: 1 035
ALT Sisyphus (unstable) (sisyphus)
# apt-get update
Получено: 1 ftp://ftp.altlinux.org Sisyphus/x86_64 release [4238B]
Ошибка ftp://ftp.altlinux.org Sisyphus/x86_64 release
  File was not signed with a known key. Check if the proper gpg key was imported to your keyring.

Лезем в :
/etc/apt/sources.list.d/alt.list

Удаляем там [alt] в трех строках.

# apt-get update
Получено: 1 ftp://ftp.altlinux.org Sisyphus/x86_64 release [4238B]
Получено: 2 ftp://ftp.altlinux.org Sisyphus/x86_64-i586 release [1680B]
Получено: 3 ftp://ftp.altlinux.org Sisyphus/noarch release [2859B]
Получено 8777B за 0s (32,3kB/s).
Получено: 1 ftp://ftp.altlinux.org Sisyphus/x86_64/classic pkglist [24,1MB]
Получено: 2 ftp://ftp.altlinux.org Sisyphus/x86_64/classic release [147B]
Получено: 3 ftp://ftp.altlinux.org Sisyphus/x86_64-i586/classic pkglist [17,7MB]
Получено: 4 ftp://ftp.altlinux.org Sisyphus/x86_64-i586/classic release [152B]
Получено: 5 ftp://ftp.altlinux.org Sisyphus/noarch/classic pkglist [7162kB]
Получено: 6 ftp://ftp.altlinux.org Sisyphus/noarch/classic release [147B]
Получено 48,9MB за 3s (13,6MB/s).               
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено

# apt-get install xfreerdp
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  xfreerdp: Требует: libfreerdp (= 2.11.2-alt1:sisyphus+334471.3400.2.1)
E: Извините, `битые' пакеты

Как то это побороть можно ?

Или может подправить как то ключи в :
/etc/apt/vendors.list.d/alt.list
« Последнее редактирование: 12.12.2023 09:29:22 от him »

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 962
    • Домашняя страница
    • Email
Зачем систему сломали?
Андрей Черепанов (cas@)

Оффлайн him

  • Завсегдатай
  • *
  • Сообщений: 1 035
Целью сломать систему не было..
Наоборот, пытался решить проблему ..

Все, поломано без возвратно ?
Только пере установка ОС ?

Оффлайн Виктор Дуб

  • Завсегдатай
  • *
  • Сообщений: 533
Не подтверждаю.
Спойлер
[regular@host-76 ~]$ sudo apt-get update && sudo apt-get dist-upgrade
Получено: 1 http://ftp.altlinux.org Sisyphus/x86_64 release [4238B]
Получено: 2 http://ftp.altlinux.org Sisyphus/x86_64-i586 release [1680B]
Получено: 3 http://ftp.altlinux.org Sisyphus/noarch release [2859B]
Получено 8777B за 0s (93,6kB/s).                   
Найдено http://ftp.altlinux.org Sisyphus/x86_64/classic pkglist
Найдено http://ftp.altlinux.org Sisyphus/x86_64/classic release
Найдено http://ftp.altlinux.org Sisyphus/x86_64-i586/classic pkglist
Найдено http://ftp.altlinux.org Sisyphus/x86_64-i586/classic release
Найдено http://ftp.altlinux.org Sisyphus/noarch/classic pkglist
Найдено http://ftp.altlinux.org Sisyphus/noarch/classic release
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Подсчет обновлений... Завершено
0 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
[regular@host-76 ~]$

Оффлайн N0rbert

  • alt linux team
  • ***
  • Сообщений: 231
  • snk@
ключи

А какой вывод сейчас на вашей системе дает команда rpm -q alt-gpgkeys ? На полностью обновленной системе должна быть версия 0.8.65-alt1.
Не нарушена ли целостность пакетного менеджера? Покажите вывод команды

# rpm -V rpm apt alt-gpgkeys apt-conf-sisyphus

А еще попробуйте сбросить репозитории и вместо ftp обновиться через http, а затем поставить нужный пакет с помощью команд:

# apt-repo rm all
# apt-repo add sisyphus
# apt-get update
# apt-get dist-upgrade
# apt-get install xfreerdp
« Последнее редактирование: 13.12.2023 01:11:29 от N0rbert »

Оффлайн him

  • Завсегдатай
  • *
  • Сообщений: 1 035
# rpm -q alt-gpgkeys
alt-gpgkeys-0.7.151-alt1.noarch

# rpm -V rpm apt alt-gpgkeys apt-conf-sisyphus
S.5....T.  c /etc/rpm/macros
S.5....T.  c /etc/apt/sources.list
S.5....T.  c /etc/apt/sources.list.d/alt.list
S.5....T.  c /etc/apt/sources.list.d/dcby.list
S.5....T.  c /etc/apt/sources.list.d/heanet.list
S.5....T.  c /etc/apt/sources.list.d/ipsl.list
S.5....T.  c /etc/apt/sources.list.d/msu.list
S.5....T.  c /etc/apt/sources.list.d/yandex.list

Третий блок начинающийся с
apt-repo rm all
выполняем ?

[alt] - для проверки ключа возвращаем в конфигурационном файле ?

Оффлайн stranger573

  • Мастер
  • ***
  • Сообщений: 1 517
    • Email
# rpm -q alt-gpgkeys
alt-gpgkeys-0.7.151-alt1.noarch
2018 года рождения, т.е. система никогда не обновлялась. Зато в неё чего-то ставилось и ковырялось.

Оффлайн N0rbert

  • alt linux team
  • ***
  • Сообщений: 231
  • snk@
Третий блок начинающийся с
apt-repo rm all
выполняем ?

Похоже что в вашем случае нужно сначала скачать вручную пакеты свежих ключей и далее обновляться

# cd /tmp
# wget -c https://git.altlinux.org/tasks/336137/build/100/x86_64/rpms/alt-gpgkeys-0.8.65-alt1.noarch.rpm --no-check-certificate
# wget -c https://git.altlinux.org/tasks/330884/build/200/x86_64/rpms/apt-conf-sisyphus-10.96-alt2.x86_64.rpm --no-check-certificate
# apt-get install ./alt-gpgkeys-0.8.65-alt1.noarch.rpm ./apt-conf-sisyphus-10.96-alt2.x86_64.rpm

# apt-repo rm all
# apt-repo add sisyphus
# apt-get update
# apt-get dist-upgrade --no-remove


А дальше нужно внимательно читать что вам будет предложено удалить и как-то предотвращать это.

Чисто ради интереса провел эксперимент на regular-kde4-20180418-i586.iso (взял 32 бита, т.к. она меньше) в VirtualBox (видеодрайвер VBoxVGA), чтобы убедиться во всесильности apt-rpm.
Тут у меня в дополнение к первому блоку команд (из этого сообщения выше) получились такие шаги по получению актуализированной работоспособной регулярки KDE 5 с видеодрайвером VMSVGA:

# apt-get remove openssh-server
# apt-get install apt libapt rpm apt-conf-sisyphus gnupg basesystem shadow-utils util-linux zstd systemd libcrypto3 cdparanoia samba-common
# apt-get dist-upgrade
# apt-get install aptitude
# aptitude dist-upgrade
# update-kernel -t std-def -a -f -y
# apt-get install sddm
# systemctl enable sddm
# apt-get install kde5
# reboot

У вас процесс может идти иначе и сложнее.

Поэтому проще всего сохранить список установленных пакетов (rpm -qa --qf "%{NAME}\n") и пользовательские данные
и затем выполнить чистую переустановку на стабильную p10, а с регулярками играть в среде виртуальной машины.
« Последнее редактирование: 14.12.2023 00:19:27 от N0rbert »

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 10 259
Не подтверждаю.
Спойлер
[regular@host-76 ~]$ sudo apt-get update && sudo apt-get dist-upgrade
Получено: 1 http://ftp.altlinux.org Sisyphus/x86_64 release [4238B]
Получено: 2 http://ftp.altlinux.org Sisyphus/x86_64-i586 release [1680B]
Получено: 3 http://ftp.altlinux.org Sisyphus/noarch release [2859B]
Получено 8777B за 0s (93,6kB/s).                   
Найдено http://ftp.altlinux.org Sisyphus/x86_64/classic pkglist
Найдено http://ftp.altlinux.org Sisyphus/x86_64/classic release
Найдено http://ftp.altlinux.org Sisyphus/x86_64-i586/classic pkglist
Найдено http://ftp.altlinux.org Sisyphus/x86_64-i586/classic release
Найдено http://ftp.altlinux.org Sisyphus/noarch/classic pkglist
Найдено http://ftp.altlinux.org Sisyphus/noarch/classic release
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Подсчет обновлений... Завершено
0 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
[regular@host-76 ~]$

Что не подтверждаю? Вы что, слепой? Не видите что у топикстартера протокол ftp?

Оффлайн ASte

  • Мастер
  • ***
  • Сообщений: 1 557
Не видите что у топикстартера протокол ftp?
А как это может влиять на отсутствие в системе актуальных ключей и на  проблемы с зависимостями? По моему если списки пакетов успешно скачались то http или ftp уже не важно...  Вот если бы со скачиванием была проблема, тогда да, протокол был бы важен.. 

Оффлайн artenaki

  • Давно тут
  • **
  • Сообщений: 198
Re: Ошибка при обновлении репозитория
« Ответ #10 : 16.12.2023 19:10:22 »
ftp серверы обычно банят IP чуть что, капризный протокол по факту.

Оффлайн ASte

  • Мастер
  • ***
  • Сообщений: 1 557
Re: Ошибка при обновлении репозитория
« Ответ #11 : 16.12.2023 19:37:04 »
ftp серверы обычно банят IP чуть что, капризный протокол по факту.
Тогда была бы ошибка при скачивании. разве нет?