Автор Тема: Ошибка при обновлении ALT 10.3, конфилкт filesystem-3.1 и filesystem-2.3.19  (Прочитано 591 раз)

Оффлайн mrsclick

  • Начинающий
  • *
  • Сообщений: 26
Текущая версия, ALT 10.3:
Цитировать
Operating System: ALT 10.3
KDE Plasma Version: 5.27.11
KDE Frameworks Version: 5.115.0
Qt Version: 5.15.13
Kernel Version: 6.1.86-std-def-alt1 (64-bit)

Репозиторий Sisyphus:
# cat /etc/apt/sources.list

# Local package resource list for APT goes here.
# To inspect package defined part, see /etc/apt/sources.list.d/*.list

rpm [alt] http://ftp.altlinux.org/pub/distributions ALTLinux/Sisyphus/x86_64 classic gostcrypto
rpm [alt] http://ftp.altlinux.org/pub/distributions ALTLinux/Sisyphus/noarch classic
rpm [alt] http://ftp.altlinux.org/pub/distributions ALTLinux/Sisyphus/x86_64-i586 classic

Очередное выполнение apt-get update с последующим apt-get dist-upgrade завершилось с ошибками:

filesystem-3.1-alt1: Migration is needed before the package can be installed.
error: lua script failed: [string "%pretrans(filesystem-3.1-alt1.x86_64)"]:29: Looks like usrmerge-hier-convert is not installed. Aborting.
Preparing...                                                                                                                    #################################################################################################### [100%]
        file /bin from install of filesystem-3.1-alt1.x86_64 conflicts with file from package filesystem-2.3.19-alt1.x86_64
        file /lib from install of filesystem-3.1-alt1.x86_64 conflicts with file from package filesystem-2.3.19-alt1.x86_64
        file /lib64 from install of filesystem-3.1-alt1.x86_64 conflicts with file from package filesystem-2.3.19-alt1.x86_64
        file /libx32 from install of filesystem-3.1-alt1.x86_64 conflicts with file from package filesystem-2.3.19-alt1.x86_64
        file /sbin from install of filesystem-3.1-alt1.x86_64 conflicts with file from package filesystem-2.3.19-alt1.x86_64
E: Error while running transaction

После установки пакета usrmerge-hier-convert, всё равно завершается с ошибками:

filesystem-3.1-alt1: Migration is needed before the package can be installed.
filesystem-3.1-alt1: Starting usrmerge-hier-convert...
usr-m: Making a copy of `/bin'.
usr-m: Detecting relative symlinks in `/bin' that would break.
usr-m: Resolving conflicts of `/bin' and `/usr/bin'.
usr-m: N: Will replace /bin/ping with /usr/bin/ping
usr-m: N: Will replace /bin/ping6 with /usr/bin/ping6
usr-m: N: Will replace /bin/zcat with /usr/bin/zcat
usr-m: N: Will replace /bin/bunzip2 with /usr/bin/bunzip2
usr-m: N: Will replace /bin/tracepath6 with /usr/bin/tracepath6
usr-m: N: Will replace /bin/gunzip with /usr/bin/gunzip
usr-m: N: Will replace /bin/awk with /usr/bin/awk
usr-m: N: Will replace /bin/bzcat with /usr/bin/bzcat
usr-m: E: /bin/ex conflicts with /usr/bin/ex; not resolving.
     : /bin/ex:     symbolic link to vi
     : /usr/bin/ex: symbolic link to vim
     : Exiting.
usr-m: No potentially destructive changes done, cleaning up.
error: lua script failed: [string "%pretrans(filesystem-3.1-alt1.x86_64)"]:32: exit
Preparing...                                                                                                                    #################################################################################################### [100%]
        file /bin from install of filesystem-3.1-alt1.x86_64 conflicts with file from package filesystem-2.3.19-alt1.x86_64
        file /lib from install of filesystem-3.1-alt1.x86_64 conflicts with file from package filesystem-2.3.19-alt1.x86_64
        file /lib64 from install of filesystem-3.1-alt1.x86_64 conflicts with file from package filesystem-2.3.19-alt1.x86_64
        file /libx32 from install of filesystem-3.1-alt1.x86_64 conflicts with file from package filesystem-2.3.19-alt1.x86_64
        file /sbin from install of filesystem-3.1-alt1.x86_64 conflicts with file from package filesystem-2.3.19-alt1.x86_64
E: Error while running transaction

Сообщение о конфикте файлов пакетов filesystem-3.1-alt1.x86_64 и filesystem-2.3.19-alt1.x86_64 понятно, но что с этим делать не ясно.

Подскажите, пожалуйста.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 32 300
  • Учиться .... Телепатами не рождаются, ими ....
    • Email

Оффлайн mrsclick

  • Начинающий
  • *
  • Сообщений: 26
usrmerge-hier-convert

Цитировать
После установки пакета usrmerge-hier-convert, всё равно завершается с ошибками

На одной из приведённых вами страниц было написано удалить\убновить vim. Перечитал вывод с ошибками и там действительно было что - то про vim.
Снёс временно vim, и обновление вроде пошло. Спасибо  ;-).

Оффлайн mrsclick

  • Начинающий
  • *
  • Сообщений: 26
Итого, успешно обновидлся до:
Цитировать
Operating System: ALT 10.3
KDE Plasma Version: 5.27.11
KDE Frameworks Version: 5.115.0
Qt Version: 5.15.13
Kernel Version: 6.1.90-std-def-alt1 (64-bit)

Спасибо ещё раз, тему закрываю.