Автор Тема: RPM с новым сжатием (PayloadIsLzma)  (Прочитано 8324 раз)

Оффлайн astroill

  • Давно тут
  • **
  • Сообщений: 51
  • Астрономия и Линукс!
    • Кубанский Астроклуб 45
    • Email
# apt-get install rpm
The following packages have unmet dependencies:
  rpm: PreDepends: librpm (= 4.0.4-alt96.7) but 4.0.4-alt81 is to be installed
       PreDepends: librpmbuild (= 4.0.4-alt96.7) but 4.0.4-alt81 is to be installed
       Depends: libpopt.so.0(LIBPOPT_0)
E: Broken packages

# apt-get install rpm librpm librpmbuild libpopt
The following packages have unmet dependencies:
  libpopt: PreDepends: rpmlib(PayloadIsLzma) (<= 4.4.2-1) but it is not installable
E: Broken packages

Проверил на сегодняшнем Сизифе, тоже самое.
Есть готовое решение или переоткрыть баг?

ЗЫ. Как вы можете понять, сюда http://lists.altlinux.org/pipermail/sisyphus/2008-June/215448.html и сюда http://freesource.info/wiki/AltLinux/Sisyphus/changes/rpm
можете не посылать.
Все, что я пишу - ИМХО и может не совпадать с реальностью.

Оффлайн Genix

  • alt linux team
  • ***
  • Сообщений: 16
Re: RPM с новым сжатием (PayloadIsLzma)
« Ответ #1 : 20.10.2008 18:53:36 »
обновляетесь с какой системы?
У каждого в башке свои тараканы...

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email

Оффлайн wRAR

  • Давно тут
  • **
  • Сообщений: 469
Re: RPM с новым сжатием (PayloadIsLzma)
« Ответ #3 : 20.10.2008 19:33:25 »
Есть готовое решение
Промежуточный репо, хихи.

Оффлайн astroill

  • Давно тут
  • **
  • Сообщений: 51
  • Астрономия и Линукс!
    • Кубанский Астроклуб 45
    • Email
Re: RPM с новым сжатием (PayloadIsLzma)
« Ответ #4 : 21.10.2008 08:16:36 »
Я лично обновился. Я думал если у кого возникнут проблемы, то могу помочь советом.
А сюда можно ?
А смысл?  ;)
обновляетесь с какой системы?
С Сизифа 2-3 месячной давности.
Все, что я пишу - ИМХО и может не совпадать с реальностью.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: RPM с новым сжатием (PayloadIsLzma)
« Ответ #5 : 21.10.2008 10:17:22 »
В 4.1 уже новый rpm, а в 4.0 - старый (вернее новый, но с отключённым lzma)

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 131
Re: RPM с новым сжатием (PayloadIsLzma)
« Ответ #6 : 21.10.2008 11:22:30 »
Я лично обновился. Я думал если у кого возникнут проблемы, то могу помочь советом.
А сюда можно ?
А смысл?  ;)
обновляетесь с какой системы?
С Сизифа 2-3 месячной давности.


Поставьте rpm из branch/4.1, потом уже обновляйтесь до Sisyphus

Оффлайн astroill

  • Давно тут
  • **
  • Сообщений: 51
  • Астрономия и Линукс!
    • Кубанский Астроклуб 45
    • Email
Re: RPM с новым сжатием (PayloadIsLzma)
« Ответ #7 : 21.10.2008 13:20:42 »
Я из пакета rpm-static с помощю mc вытащил rpm.static (установить этот пакет тоже нельзя, т.к. он зависит от rpm, а он в свою очередь... св. выше).
И дальше:
# ./rpm.static -Uvh rpm-новый librpm-новый librpmbuild-новый libpopt-новый
После этого:
# apt-get --reinstall update
# apt-get dist-upgrade
Т.е. не привлекая сторонние пакеты.
В 4.1 уже новый rpm, а в 4.0 - старый (вернее новый, но с отключённым lzma)
В 4.1 это уже разрулено или все кто будут обновляться с 4.0 (и старше) на 4.1 (и выше) будут сталкиваться с этим?
« Последнее редактирование: 21.10.2008 13:27:07 от astroill »
Все, что я пишу - ИМХО и может не совпадать с реальностью.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: RPM с новым сжатием (PayloadIsLzma)
« Ответ #8 : 21.10.2008 17:06:58 »
В 4.1 это уже разрулено

Оффлайн astroill

  • Давно тут
  • **
  • Сообщений: 51
  • Астрономия и Линукс!
    • Кубанский Астроклуб 45
    • Email
Re: RPM с новым сжатием (PayloadIsLzma)
« Ответ #9 : 22.10.2008 08:14:57 »
Понятно.
Дома получилось только:
# rpm.static -Uvh --nodeps rpm-новый librpm-новый librpmbuild-новый libpopt-новый
Ну а дальше все как по-маслу.
Все, что я пишу - ИМХО и может не совпадать с реальностью.

Оффлайн Darrggon

  • Завсегдатай
  • *
  • Сообщений: 8
    • Email
Re: RPM с новым сжатием (PayloadIsLzma)
« Ответ #10 : 24.10.2008 11:36:20 »
Понятно.
Дома получилось только:
# rpm.static -Uvh --nodeps rpm-новый librpm-новый librpmbuild-новый libpopt-новый
Ну а дальше все как по-маслу.

У меня Alt Linux 4.0 Desktop Professional
А можно новичку написать точно, какие именно команды с цифирками нужно вбить чтобы это решилось.
Ведь Если я напишу rpm.static -Uvh --nodeps rpm-новый librpm-новый librpmbuild-новый libpopt-новый
система меня не поймет и будет права.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: RPM с новым сжатием (PayloadIsLzma)
« Ответ #11 : 24.10.2008 11:43:36 »
Так циферки меняются :) Обновили бренч и цифры другие. Решение простое - прежде чем переходить на бренч 4.1, перейдите на бренч 4.0, обновите систему, а потом без описанных выше проблем перейдёте на бренч 4.1

Оффлайн Bickaze

  • Давно тут
  • **
  • Сообщений: 86
  • Desktop 4.0
    • Студия Браво
Re: RPM с новым сжатием (PayloadIsLzma)
« Ответ #12 : 11.01.2009 06:27:10 »
В 4.1 уже новый rpm, а в 4.0 - старый (вернее новый, но с отключённым lzma)
не подскажите как его включить?
Desktop 4.0

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: RPM с новым сжатием (PayloadIsLzma)
« Ответ #13 : 11.01.2009 10:43:16 »
а зачем ?

Оффлайн Bickaze

  • Давно тут
  • **
  • Сообщений: 86
  • Desktop 4.0
    • Студия Браво
Re: RPM с новым сжатием (PayloadIsLzma)
« Ответ #14 : 11.01.2009 11:15:44 »
а зачем ?
  установка новых программ с расширением рпм требует этого.
Desktop 4.0