Автор Тема: Каких пакетов не хватает в Sisyphus  (Прочитано 215893 раз)

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Каких пакетов не хватает в ALT Linux
« Ответ #780 : 05.08.2017 06:27:00 »
Антон. Можешь напрямую с Геннадием поговорить ;-) Конечно можно, но там есть свои соображения ;-)

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 7 997
  • UNIX System V init
Re: Каких пакетов не хватает в ALT Linux
« Ответ #781 : 05.08.2017 10:22:28 »
Для информации:
В p8/branch
$ apt-cache show opera-dev|grep ^File
Filename: opera-dev-46.0.2556.0-alt1.i586.rpm

Последняя opera-dev для которой собирались 32bit пакеты для Линукс:
https://get.geo.opera.com/pub/opera-developer/46.0.2573.0/linux/

В последующих версиях opera-dev, выпуск 32bit пакетов для Линукс прекращён.

32bit пакеты opera-dev для Windows актуальны по сей день, доступны для скачивания и датированы 31-Jul-2017 12:31:
https://get.geo.opera.com/pub/opera-developer/48.0.2670.0/win/
ZX Spectrum 128K
Привет от NM:  # echo -e "\n[device]\nwifi.scan-rand-mac-address=no" >> /etc/NetworkManager/NetworkManager.conf

Оффлайн neobht

  • Давно тут
  • **
  • Сообщений: 390
Re: Каких пакетов не хватает в ALT Linux
« Ответ #782 : 05.08.2017 18:27:44 »
Клиент для Rocket chat: https://github.com/RocketChat/Rocket.Chat

Интересный открытый аналог Slack.
Пока используем пакет для Fedora, но если будет в репозитории - прям вообще отлично будет.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 17 308
    • Домашняя страница
    • Email
Re: Каких пакетов не хватает в ALT Linux
« Ответ #783 : 06.08.2017 06:05:13 »
А Mattermost смотрели?
Андрей Черепанов (cas@)

Оффлайн neobht

  • Давно тут
  • **
  • Сообщений: 390
Re: Каких пакетов не хватает в ALT Linux
« Ответ #784 : 06.08.2017 07:22:03 »
А Mattermost смотрели?

Нет. Только анализировали и сравнивали.
Матермост судя по описанию только в энтерпрайз имеет поддержку корпоративной авторизации LDAP, SSO, SAML, что конечно же нас не устраивает.

А рокетчат имеет даже интеграцию с jitsi meet.
В общем придумать сложно, чего бы для корпоративного применения еще дополнительно хотелось.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 17 308
    • Домашняя страница
    • Email
Re: Каких пакетов не хватает в ALT Linux
« Ответ #785 : 06.08.2017 10:38:31 »
Хорошо, давно хотелось подобное собрать.
Андрей Черепанов (cas@)

Оффлайн rabochyITs

  • Давно тут
  • **
  • Сообщений: 401
  • Евгений
Re: Каких пакетов не хватает в ALT Linux
« Ответ #786 : 09.08.2017 15:13:27 »
На днях восстанавливал файловую систему ext4, полетел суперблок, fsck не справилось, потребовалось несколько сотен ручных правок yes/no, что отняло бы много времени. Нужно было достать три каталога etc, usr, var и справилась с этим программа ext4magic. Часть работы сделал под альтами, а вот основную под ubuntu, так как нет такого пакета (ext4magic) в альтах (я не нашел). При компиляции ext4magic уперся в конфликт версии утилиты file, версии 5.04 не было:
# file -v
file-4.26
Нужно либо версию file обновить, либо ext4magic собрать/добавить в репозиторий.

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 3 218
  • antohami@
Re: Каких пакетов не хватает в ALT Linux
« Ответ #787 : 10.08.2017 15:32:59 »
Нужно либо версию file обновить, либо ext4magic собрать/добавить в репозиторий.

Без обновления file ничего не выйдет. Версию file в Альте обновляли в 2008 году, т.е. 9 лет назад! Судя по спеку SUSE, ext4magic требует file версии > 5.05. Но никто file обновлять в Альте не собирается: https://bugzilla.altlinux.org/show_bug.cgi?id=19293

Оффлайн varalt

  • Давно тут
  • **
  • Сообщений: 996
    • Email
Re: Каких пакетов не хватает в ALT Linux
« Ответ #788 : 16.08.2017 06:25:01 »
Нужно либо версию file обновить, либо ext4magic собрать/добавить в репозиторий.

Без обновления file ничего не выйдет. Версию file в Альте обновляли в 2008 году, т.е. 9 лет назад! Судя по спеку SUSE, ext4magic требует file версии > 5.05. Но никто file обновлять в Альте не собирается: https://bugzilla.altlinux.org/show_bug.cgi?id=19293

М-да, печально, что ext4magic не попадёт в наши репы... Я прочитал об ситуации с file в багзилле, но там не написано, по какой причине у нас обновленные версии пакета не собираются.

Я вот для теста попытался собрать пакет file-5.14 из исходников командами "./configure && make && make install", бинарный file в папке src появился и вроде запускается.
А вот с пакетом ext4magic-0.3.2 на этапе "./configure" возникли проблемы - попросил поставить devel-пакеты ext2fs, blkid, e2p, uuid.
Devel-пакеты blkid и uuid поставил, а остальные где мне взять?

P.S. Извините за оффтоп, но я не удержался, чтобы не отписаться о своих попытках собрать ext4magic...
 
 

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Каких пакетов не хватает в ALT Linux
« Ответ #789 : 16.08.2017 06:48:21 »
Может проще зависимость в ext4magic подправить? Как я понимаю многие фишки нового file бекпортируются в альтовскую версию file из новых версий, не поднимая номер версии.

Оффлайн varalt

  • Давно тут
  • **
  • Сообщений: 996
    • Email
Re: Каких пакетов не хватает в ALT Linux
« Ответ #790 : 16.08.2017 07:09:14 »
Может проще зависимость в ext4magic подправить? Как я понимаю многие фишки нового file бекпортируются в альтовскую версию file из новых версий, не поднимая номер версии.
Эм... И как править зависимости в ext4magic? Да и то ещё неизвестно, насколько коректно будет работать ext4magic с изменёнными зависимостями...

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 559
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Каких пакетов не хватает в ALT Linux
« Ответ #791 : 16.08.2017 07:19:10 »
- Ну, это надо смотреть исходники пакета (configure, makefile и т.п.).
- Может будет, может нет. Пока не попробуешь, не узнаешь.

Оффлайн varalt

  • Давно тут
  • **
  • Сообщений: 996
    • Email
Re: Каких пакетов не хватает в ALT Linux
« Ответ #792 : 16.08.2017 07:51:05 »
- Ну, это надо смотреть исходники пакета (configure, makefile и т.п.).
- Может будет, может нет. Пока не попробуешь, не узнаешь.
Насчёт первого - с devel-пакетами разобрался,  "./configure && make && make install" отработали штатно, ext4magic появился в /usr/local/sbin.
Насчет второго - согласен, нужен тест, да не на чём мне сейчас тестить.

Оффлайн varalt

  • Давно тут
  • **
  • Сообщений: 996
    • Email
Re: Каких пакетов не хватает в ALT Linux
« Ответ #793 : 17.08.2017 12:13:48 »
Добрый день!

Я тут решил попытаться собрать-таки ext4magic в RPM-пакет при помощи rpmbuild (я впервые занимаюсь сборкой пакета в RPM), но у меня процесс стопорится на скрипте /usr/lib/rpm/brp-alt. Выяснил, что при выполнении того скрипта почему-то создается архив ext4magic.8 с расширением xz, хотя судя по ошибке, должен создаваться с расширением gz.
В спойлер я выложил необходимый кусок лога. Кто нибудь знает, как обойти эту проблему? 

 
Спойлер

+ /usr/lib/rpm/brp-alt
Cleaning files in /tmp/.private/niss163/ext4magic-buildroot (auto)
Verifying and fixing files in /tmp/.private/niss163/ext4magic-buildroot (binconfig,pkgconfig,libtool,desktop)
Compressing files in /tmp/.private/niss163/ext4magic-buildroot (auto)
Verifying ELF objects in /tmp/.private/niss163/ext4magic-buildroot (arch=normal,fhs=normal,lfs=relaxed,lint=relaxed,rpath=normal,stack=normal,textrel=normal,unresolved=normal)
Hardlinking identical .pyc and .opt-?.pyc files
Hardlinking identical .pyc and .pyo files
Обрабатываются файлы: ext4magic-0.3.2-alt1
ошибка: Файл не найден: /tmp/.private/niss163/ext4magic-buildroot/usr/share/man/man8/ext4magic.8.gz
Выполняется(%doc): /bin/sh -e /tmp/.private/niss163/rpm-tmp.98976
+ umask 022
+ /bin/mkdir -p /home/cartelauto.local/niss163/RPM/BUILD
+ cd /home/cartelauto.local/niss163/RPM/BUILD
+ cd ext4magic-0.3.2
+ DOCDIR=/tmp/.private/niss163/ext4magic-buildroot/usr/share/doc/ext4magic-0.3.2
+ export DOCDIR
+ rm -rf /tmp/.private/niss163/ext4magic-buildroot/usr/share/doc/ext4magic-0.3.2
+ /bin/mkdir -p /tmp/.private/niss163/ext4magic-buildroot/usr/share/doc/ext4magic-0.3.2
+ cp -prL AUTHORS COPYING ChangeLog NEWS README TODO /tmp/.private/niss163/ext4magic-buildroot/usr/share/doc/ext4magic-0.3.2
+ chmod -R go-w /tmp/.private/niss163/ext4magic-buildroot/usr/share/doc/ext4magic-0.3.2
+ chmod -R a+rX /tmp/.private/niss163/ext4magic-buildroot/usr/share/doc/ext4magic-0.3.2
+ exit 0


Ошибки сборки пакетов:
    Файл не найден: /tmp/.private/niss163/ext4magic-buildroot/usr/share/man/man8/ext4magic.8.gz

Оффлайн varalt

  • Давно тут
  • **
  • Сообщений: 996
    • Email
Re: Каких пакетов не хватает в ALT Linux
« Ответ #794 : 17.08.2017 13:08:01 »
Отвечаю самому себе: пришлось менять в файле /usr/lib/rpm/---/macros тип автоматического сжатия с auto на gzip. Лишь тогда rpmbuild смог полностью собрать пакет...

Осталась маленькая загвоздка: я собрал пакет только для x86_64, как мне тогда собрать пакет для 32 bit?
При попытке указать явно target=i386 вываливается ошибка(насколько я понял, нет нужного макроса, но я не могу понять, откуда мне его поставить):
Спойлер
$ rpmbuild -ba --target=i386 ext4magic.spec
Платформы для сборки: i386
Сборка для платформы i386
предупреждение: Macro %configure not found
предупреждение: Macro %makeinstall not found
Invalid or unknown architecture: i386-alt-linux
Выполняется(%prep): /bin/sh -e /tmp/.private/niss163/rpm-tmp.98492
ошибка: Неверный код возврата из /tmp/.private/niss163/rpm-tmp.98492 (%prep)


Ошибки сборки пакетов:
    Macro %configure not found
    Macro %makeinstall not found
    Неверный код возврата из /tmp/.private/niss163/rpm-tmp.98492 (%prep)