Автор Тема: Версию Skype 4.3.x Microsoft заблокировали совсем.  (Прочитано 23837 раз)

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 2 631
  • antohami@
Версию Skype 4.3.x Microsoft заблокировали совсем. https://opennet.ru/opennews/art.shtml?num=47540
А оставшиеся версии Skype для Linux только 64 бита.
Вывод: пришло время бросать вредную привычку использовать Skype. Да и вообще проприетарщину, которая заставляет модернизировать компьютер и переходить на 64 бита ;-)

Оффлайн Kamrad

  • Давно тут
  • **
  • Сообщений: 110
  • Пингвиновод
    • Email
Версию Skype 4.3.x Microsoft заблокировали совсем.
[Censored] - они  и в Америке [censored]!
"Linux используют ...э....энтузиасты, а нормальные люди работают на Windows! Вот представьте - приучили вы ребёнка работать с Linux, а придёт он в школу, где кругом Windows - и что он будет делать?!" (аргументация менеджера в компьютерной фирме)

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 7 236
  • UNIX System V init
Версию Skype 4.3.x Microsoft заблокировали совсем.
[Censored] - они  и в Америке [censored]!

Американцы не виноваты, - это  Майкрософт. Таков мир корпораций. А с той они половины земного шара или с этой, не имеет никакого значения.
Линус Торвальдс тоже в Штатах. И Ричард Мэтью Столлман, тоже гражданин США. Список может быть длинным. Без этих американцеви многих других, Линукс даже не появился бы.
ZX Spectrum 128K
Привет от NM:  # echo -e "\n[device]\nwifi.scan-rand-mac-address=no" >> /etc/NetworkManager/NetworkManager.conf

Оффлайн Kamrad

  • Давно тут
  • **
  • Сообщений: 110
  • Пингвиновод
    • Email
Американцы не виноваты, - это  Майкрософт. Таков мир корпораций.

Да я против американцев ничего не имею. :) "Я и американским языком не владею!" (с)
"Linux используют ...э....энтузиасты, а нормальные люди работают на Windows! Вот представьте - приучили вы ребёнка работать с Linux, а придёт он в школу, где кругом Windows - и что он будет делать?!" (аргументация менеджера в компьютерной фирме)

Оффлайн Kalt

  • Давно тут
  • **
  • Сообщений: 514
Версию Skype 4.3.x Microsoft заблокировали совсем
...Здесь ещё не согласны?.. ;-D https://support.skype.com/en/faq/FA12041/what-platforms-is-skype-available-on
« Последнее редактирование: 12.11.2017 12:05:58 от Kalt »

Оффлайн K0T

  • Давно тут
  • **
  • Сообщений: 175
  • Simply 7.0.5
    • Email
...Здесь ещё не согласны?..  https://support.skype.com/en/faq/FA12041/what-platforms-is-skype-available-on

просто проглядели или руки не дошли исправить страницу, если идти далее по ссылкам, то видно
https://support.skype.com/en/faq/fa10328/what-are-the-system-requirements-for-skype
Цитировать
Skype for Linux system requirements

Linux Version
64-bit Ubuntu 14.04+
64-bit Debian 8.0+
64-bit OpenSUSE 13.3+
64-bit Fedora Linux 24+

Processor
An Intel Pentium 4 processor or later that's SSE2 and SSE3 capable

RAM
At least 512 MB

Additional software
libappindicator1 or GtkStatusIcon to make the tray icon work (optional)

Оффлайн Kalt

  • Давно тут
  • **
  • Сообщений: 514
просто проглядели или руки не дошли...
...А здесь?.. https://forum.altlinux.org/index.php?topic=532.msg319402#msg319402
...И у меня тоже всегда все версии работали, а сейчас перешёл на skypeforlinux-64-insider.rpm... :-)

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 924
http://www.opennet.ru/tips/3039_skype_linux_patch_protocol.shtml

Цитировать
Возвращение к жизни Skype 4.3 для Linux    [исправить]

Некоторое время назад компания Microsoft начала блокировать работу
классического клиента Skype 4.3 для Linux, стимулируя переход на новую ветку
Skype 8.x. При этом блокировка не обусловлена техническими причинами и работа
Skype 4.3 для Linux может быть восстановлена простой заменой номера версии  в
исполняемом файле.

В частности, если в любом бинарном редакторе заменить строку "4.3.0.37" на
"8.3.0.37" в /usr/bin/skype, то старый клиент Skype  продолжит свою нормальную работу.

Для изменения можно запустить:

   sudo sed -i 's/4\.3\.0\.37/8\.3\.0\.37/' /usr/bin/skype

Сам не проверял.

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 7 236
  • UNIX System V init
http://www.opennet.ru/tips/3039_skype_linux_patch_protocol.shtml

Цитировать
Возвращение к жизни Skype 4.3 для Linux    [исправить]

В частности, если в любом бинарном редакторе заменить строку "4.3.0.37" на
"8.3.0.37" в /usr/bin/skype, то старый клиент Skype  продолжит свою нормальную работу.

Для изменения можно запустить:

   sudo sed -i 's/4\.3\.0\.37/8\.3\.0\.37/' /usr/bin/skype

Сам не проверял.

Проверял оба варианта на эхо, с sed и с dd:
https://forum.altlinux.org/index.php?topic=532.msg319657#msg319657
https://forum.altlinux.org/index.php?topic=532.msg319660#msg319660
ZX Spectrum 128K
Привет от NM:  # echo -e "\n[device]\nwifi.scan-rand-mac-address=no" >> /etc/NetworkManager/NetworkManager.conf

Оффлайн sparov

  • Начинающий
  • *
  • Сообщений: 3
В частности, если в любом бинарном редакторе заменить строку "4.3.0.37" на
"8.3.0.37" в /usr/bin/skype, то старый клиент Skype  продолжит свою нормальную работу.
Проверил. Заработало. Спасибо!

Оффлайн Winlin

  • Давно тут
  • **
  • Сообщений: 187
http://www.opennet.ru/tips/3039_skype_linux_patch_protocol.shtml

Цитировать
Возвращение к жизни Skype 4.3 для Linux    [исправить]

Некоторое время назад компания Microsoft начала блокировать работу
классического клиента Skype 4.3 для Linux, стимулируя переход на новую ветку
Skype 8.x. При этом блокировка не обусловлена техническими причинами и работа
Skype 4.3 для Linux может быть восстановлена простой заменой номера версии  в
исполняемом файле.

Для изменения можно запустить:

   sudo sed -i 's/4\.3\.0\.37/8\.3\.0\.37/' /usr/bin/skype
Спасибо!
На 32-разрядном ALT Linux 7.0.5 KDesktop сработало!

Оффлайн Winlin

  • Давно тут
  • **
  • Сообщений: 187
На 32-разрядном ALT Linux 7.0.5 KDesktop сработало!
Перестало работать. Не проходят вызовы на скайп. И не принимаются вызовы.
Но звонки на телефон работают.
Это только у меня такая проблема или Майкрофт прикрыл эту лазейку?

Оффлайн Winlin

  • Давно тут
  • **
  • Сообщений: 187
Подмена номера версии на новые не помогает.
Сам скайп запускается. Не работают звонки на скайп. Звонки на телефоны работают. Текстовые сообщения работают.
Можно как-то это исправить?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 16 887
    • Домашняя страница
    • Email
Да. Перейти на новую версию Skype или использовать web.skype.com.
Андрей Черепанов (cas@)

Оффлайн Winlin

  • Давно тут
  • **
  • Сообщений: 187
Да. Перейти на новую версию Skype или использовать web.skype.com.
Так более новой, чем 4.3.0.37 для 32-разрядного линукса нет.
Веб скайп на 32-разрядном ALT Linux 7.0.5 KDesktop - не работает ни на файрфоксе, ни на хромиуме, ни на пейлмуне.
Кто-нибудь ещё на 32-разрядном 7-ом альте скайп использует? Скайп работает?
Или только я один остался  :-)?